Team Camaro Tech banner

1 - 6 of 6 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
I have a 1967 Coupe with 161,000 miles on it. It started cutting out while going up steep hills at highway speeds recently. It runs fine other than that and I've had it tuned up (new wires, fuel pump, 2bbl carb overhauled and the tuning/timing checked again) with no improvement. I understand it's time for an overhaul one of these days but would like to keep her running well for another year or so as is. I'm stumped and so are others who have tried to solve the problem. Anyone out there have a solution?

------------------


Plain Jane straight 67 Coupe 327 2bbl pglide. Bought when 17 (1982) and is nearly original but have all parts to put it back one of these days. The 2bbl probably kept me from wraping it around a tree when younger...
 

·
Registered
Joined
·
501 Posts
Back in the old days, Model-T's used to have this problem...they didn't use fuel pumps...they used a down draft system (gravity) which located the gas tank right above the driver's lap. But if you were traveling up steep grade, no fuel would reach the carb. The solution for this was to turn around and back up the hill. Crazy!

Your problem is the float setting in your carb. On an upward incline, the fuel is pulled to the rear of the float bowl...the float "says" everything is fine, yet the the jets are thirsty.

Have whoever rebuilt your carb do a better job measuring the float setting.

Good luck!
 

·
Registered
Joined
·
85 Posts
<BLOCKQUOTE>quote:</font><HR>Originally posted by Sleepy-69:
Back in the old days, Model-T's used to have this problem...they didn't use fuel pumps...they used a down draft system (gravity) which located the gas tank right above the driver's lap. But if you were traveling up steep grade, no fuel would reach the carb. The solution for this was to turn around and back up the hill. Crazy!

Your problem is the float setting in your carb. On an upward incline, the fuel is pulled to the rear of the float bowl...the float "says" everything is fine, yet the the jets are thirsty.

Have whoever rebuilt your carb do a better job measuring the float setting.

Good luck!
<HR></BLOCKQUOTE>

I agree totally! Also did you change your fuel filter when you did the new pump?



------------------
Prowling the Streets for rustangs
 

·
Registered
Joined
·
579 Posts
If the filter has a drain back valve in the inlet, remove it, I have had these cause more problems than any thing else, You don't need it for a 2bbl carb of this vintage.
 

·
Premium Member
Joined
·
13,705 Posts
Don't know if anyone has hit upon anything that has been of help yet, but I would add that I have traced problems like this in the past to the fuel tank, fuel line (specially the rubber line at the tank), and even the 'sock' that is present on some fuel tank pick-ups being clogged. You live in an area that fuel tank rusting can be a problem, so if all else fails I would recommend pulling the tank and opening it up to see how things are inside. As a temporary try - you can try blowing back throught the fuel line from the pump to the tank (keep the air pressure under 20psi) to see if something is stuck in the system and you can blow it out.
 

·
Registered
Joined
·
352 Posts
Change your fuel filter first before you do anything else. I had the same problem years ago, it was the fuel filter.
 
1 - 6 of 6 Posts
Top