Team Camaro Tech banner

1 - 7 of 7 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter #1
Just put on a new carb on the other day{holley 650 double pumper} and I've been having problems.I know out of the box they are not going to run perfect so I wasn't surprised when I went to fire it up and gas shot out of the slosh tubes. After ajusting the floats it ran fine until this morning. I went to start it up and it just would'nt fire. Cause it was flooded. I waited for a little bit and gave it another try. It started and sounded really bad. I shut it off and saw gas just pouring out of the venturies. What do I need to do to fix this?
 

·
Registered
Joined
·
522 Posts
Sound like the floats still need some adjusting. The clear plugs for the bowls work great, and you dont have to spill any gas. Just adjust the floats until you see the miniscus of the gas on the bottom of the clear plug.
If you already have done that and it remains at the same level during idle, what is your fuel pressure? anything over 6.5 psi will flood out a holley and foul the plugs quick.
I am by no means an expert on holly carbs so this is just the first step towards adjusting the carb. Any one wlse with some advice?

------------------
Tim
67 ss/rs, Stock? Not!!
Visit my page!!
 

·
Registered
Joined
·
63 Posts
Discussion Starter #3
Thanks for the advice I'll try anything at this point. Hey your car looks great!

------------------
70 1/2 RS Camaro
 

·
Registered
Joined
·
294 Posts
Make sure that you have a quality fuel filter installed, holleys do not like foreign material.

------------------
69 rallye green X77 Z/28,1967 SS 396 Conv. 1974 c-10 454 swb
 

·
Registered
Joined
·
5,962 Posts
Sounds like you better check your oil for fuel! If you dumped that much gas down the intake you probably got some in the oil. It sounds like you got some trash in the needle and seat assymbly. You probably need to remove them and blow them out with compressed air. You realy need a good fuel filter just before the carb. Has the engine backfired through the carb? If it did you may have busted the power valve too.

------------------
'69 RS/SS396 pro street
427/4spd/9"
 

·
In the 10's Moderator
Joined
·
19,783 Posts
Also check your fuel pressure, 7-8psi max... although you didn't say mach. or elect. fuel pump.
And yes, check your oil,may wash out the bearings...depends on how much and how long.

------------------
My '68 Camaro
Doug G.
68 Camaro
406 ci.
 

·
Registered
Joined
·
63 Posts
Discussion Starter #7
My fuel pump is mechanical and is putting out around 7 psi. Checked the oil but I can't tell if there is gas in it because I have a cold and can't smell anything. I'll change it just in case.

------------------
70 1/2 RS Camaro
 
1 - 7 of 7 Posts
Top