Team Camaro Tech banner

1 - 10 of 10 Posts

·
Registered
Joined
·
102 Posts
Discussion Starter #1
Is this a better rebuilt Carb than the AutoZone or O'Reillys? I have had some real junk rebuilds from AZone. Just didn't want to try one if not worth the difference.

http://store.summitracing.com/egnsearch.asp?N=700+400178+308351+4294908216+4294840133+4294925073+115+4294908189&autoview=sku

My 74 454 runs like a ginny until you go WOT..then it bogs from 3800 +.

Acts like it's draining the bowl. :mad:

Timing is at 12 initial....36 at 3000 with mechanical all in.....51 degrees total. Totally NEW motor.

I give up....its gotta be this carb. :confused:
 

·
Registered
Joined
·
1,902 Posts
it sounds like the back 2 barrels arent opening and than causing your bog down. you can take air cleaner off open top flaps and floor it to see if the bottom flaps open up.that will tell you mechanical linkage is opening it. than start car and floor it top flaps should open if they dont which mostly be your problem.now to fix problem choke is set much which will block 4 barrels from opening. not adjusted right. theres a screw on side to let open quicker or slower on top side of carb.the top flapper or barrel is opened by vacumn from inside of engine. as vacumn drops it opens flapper and puts more fuel in.i dont have a picture of what to adjust on a rochester. but there are web sights out there to do it. if you want me to get the info ill get it for you.
 

·
Registered
Joined
·
102 Posts
Discussion Starter #4
Yea...y'all are right. Probably just need to fine tune the one I have. Just frustrated.

Thanks.....I'll take a break...then get started again.
 

·
Registered
Joined
·
5,277 Posts
I was thinking the secondaries may be opening too soon causing a bog.
 

·
Registered
Joined
·
102 Posts
Discussion Starter #6 (Edited)
OK....UPDATE !

Original Problem was:

My 74 (brand new motor) 454 runs great until you go WOT..then it bogs from 3800 +.
Acts like it's draining the bowl.
I give up....its gotta be this carb.

UPDATE :D

My bud at the junkiest old garage in town said...."Take the little fuel filter out of that Q-Jet....remove that stupid one-way check valve....put the little filter back in. That big block wants real stupid fuel flow under WOT.....the one way valve won't give it the gas it needs.....I reckon it ain't getting no gas".

I tried it today.....it fixed the BOG problem I've been fighting for the last 3 months, It now runs like a Saturn IV rocket booster til you let off the gas because it's too scarey ..... At 50 mph it will break loose and leave about 60 feet of double black marks when it drops down to D2. .. .:hurray:

I appreciate you guys tolerating a Vette guy....this is the best engine forum I have ever seen. This 74 Big Block convertible is the last of "the breed". I may sell my 72 SB T-Top and start looking for a nice 70.5 Camaro.

 

·
Premium Member
Joined
·
8,375 Posts
I hate it when that happens.:sad:
 

·
Premium Member
Joined
·
6,360 Posts
One of the MANY trix to them ol QJ's...
 

·
Super Moderator
Joined
·
32,431 Posts
Glad you found a fix. The first action I do to any Q-jet, or any carb, is to remove the inlet filter and go external.
 
1 - 10 of 10 Posts
Top