Team Camaro Tech banner
1 - 9 of 9 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter · #1 ·
Hi All:
I just installed a clutchmasters FX400 clutch on my 68 ss big block. All clutches I have used previously include paperwork specifying a 500 mile breakin period before application of full power. If everyone adhered to this it would be a long time between clutch changes and visits to the race track. Can anyone offer an opinion on this? Is it a CYA statement? What is the minimum breakin required? I drove the car around town yesterday with a bit of highway driving and am planning to go to the track tomorrow. Should I expect any problems? Any opinions would be appreciated.

Thanks,

Scott
 

·
Premium Member
Joined
·
2,177 Posts
When we installed our Centerforce Dual Friction setup, it to was a 500 mile breakin. That was the longest 500 miles ever. Don't really know for sure if not breaking it in would cause problems but going racing might be a little early.
 

·
Registered
Joined
·
741 Posts
I had less than 50 miles on my clutch when it saw the drag strip (Mcleod street twin).
500 mile break in, was rec on it too. I got my best 60 foots on that trip, I'll assume it had just a little slip.:hurray:
The "street" twin, turned out to be a great "street":confused: clutch, but after the 500 or so mile break in, it either caused the tires to spin, or when it hooked, I broke parts.:sad:
I'm getting a new adjustable clutch built, need that little slip at launch:cool:
---Bill.
 

·
Banned
Joined
·
21,341 Posts
Look, just daily drive it for say a couple to three weeks like you used to when you first got your car if you got it waaaay back then as your daily driver and you will be fine, imho..

pdq67
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #9 ·
Hi Guys:
A lot of fun at the track but not great times. Still having a lot of trouble hooking up. Lot of tire spin off the line. So here are the times:

Pass 1
60' 2.164
ET 13.807
MPH 102.28

Pass 2
60' 2.071
ET 13.579
102.04

Pass 3

60' 2.025
ET 13.677
MPH 101.13


60' was getting better with each pass as you can see. On pass #4 the car ahead of me broke while staging. Took a long time to get him going and my motor got hot. After my burnout the motor quit and the battery went flat and I had to be pushed out of the way. So that was pretty much the end of the day for me. It was open class test and tune at Gateway so a long time between passes. I'm installing a line lock today and that will help with my burnouts and 60' times. Was using MT ET streets for the first time and I just couldn't keep the burnout long enough to properly heat the tires. They were just grabbing too soon. Can't seem to manage the heel and toe technique. I'm hoping to get back out there tomorrow night. If I can make it I will post the results.

Scott
 
1 - 9 of 9 Posts
Top