Team Camaro Tech banner

1 - 8 of 8 Posts

·
Premium Member
Joined
·
39 Posts
Discussion Starter #1
Hey guys, I recently received the CPP 500 series steering box, master cylinder & 11" booster (4 wheel disc setup). The master cylinder kit and brake booster seem all setup and ready to go (minus the paint for MC).

When I try to bolt the booster to the firewall, the bracket sits about 1" from the firewall because the round plastic part that looks like it should go through the firewall is a little too big. If that round plastic part would fit through the firewall, everything would bolt up nicely. Is it just a matter of widening the hole it is supposed to go through? Or is there something I'm missing? I can't seem to find information on this, all the videos I've found make it look like a simple bolt up install.

Thank you!!
 

·
Premium Member
Ben - Delaware - 67 Camaro
Joined
·
512 Posts
post pictures. i think the plastic part you're talking about may be packaging protection that gets removed before install but can't remember
 

·
Premium Member
Joined
·
39 Posts
Discussion Starter #3
I can't seem to get the pictures to attach, I've resized the jpgs as small as I can, but after I drag them in they just disappear. Maybe it's the probationer status?

I can pull the plastic part off, but there is a black lubed plastic piece that would just sit exposed if I take if off.
 

·
Premium Member
Ben - Delaware - 67 Camaro
Joined
·
512 Posts
are we talking about the white / clear plastic piece covering the foam on the end of the one in the attached picture? if so, i'm 99% that went in the trash during my install and cant remember if the foam goes through the hole or if that hit the trash can too. looks like packaging protection.....BTW, don't even ask me why i have pictures of parts in boxes and not pictures "during" install. i've got the attached pic and then in everything else it's mounted on the firewall.

maybe one of the very many more knowledgeable people than me will chime in
 

Attachments

·
Premium Member
Joined
·
39 Posts
Discussion Starter #5
That is the exact part though! I think we all do pics when we open a box of car parts :) haha. Well, if it is trash, which it is sounding like it is, glad its easy and I'm just a dummy. Why would the part underneath that plastic have grease / lube on it though? It looks like it would just sit between the mounting bracket and collect dirt.
 

·
Premium Member
Ben - Delaware - 67 Camaro
Joined
·
512 Posts
I'm still not 100% sure, but 99.9% that i threw all that jazz out. it's been a few years but i can attest to having fully functioning power brakes without issues too date
 

·
Premium Member
Ben - Delaware - 67 Camaro
Joined
·
512 Posts
i think you're talking about the rod the clevis mounts too that goes through the firewall...pushrod, or clevis rod or whatever it's "official" name is. if so, all that plastic and foam crap goes away the the rod rides in the black sleeve. once mounted, it will be on the inside of the car under your dash so i wouldn't worry about it being exposed.
 

·
Premium Member
Joined
·
39 Posts
Discussion Starter #8
Thank you very much, even though it ended up being a silly question, I found one video of a guy putting it in a 55 Chevy or something like that and I'm pretty sure he trimmed around the plastic! It didn't seem right, so I'm glad I came here! You guys rock!
 
1 - 8 of 8 Posts
Top