Team Camaro Tech banner

1 - 7 of 7 Posts

·
Registered
Joined
·
126 Posts
Discussion Starter #1
:confused:Can someone help me out on my dash lights for a 67 Camaro for some wierd reason my dash lights don't turn on when I pull the light switch on :confused:
 

·
Premium Member
Joined
·
22,122 Posts
First things first, rotota the switch knob fully CCW, did that help?
Check the Gauges fuse, it's the short one at the bottom on the fusebox, 4 amps, do you have power there?
Does the light in the heater control light up?
Shift quadrant light? (If auto / console)?
 

·
Registered
Joined
·
1,222 Posts
And the "gauge" fuse is energized by the light switch, not vice versa.
If the light switch is not 'on', there is no 12v+.
 

·
Registered
Joined
·
126 Posts
Discussion Starter #5
Well There is a current and all the fuses are fine and the Heater Contol Dosen't light up either I checked it last night and couldn't fine anything i check later on and check the gauges and everything to make sure there is no losse connection
 

·
Registered
Joined
·
1,222 Posts
When you say there is current do you mean there is 12v + on the small instr lps fuse?

Does the V+ cycle as you turn the headlight switch off and on, as you have a meter on the small instr lps fuse?

I just had to repair mine last weekend, and on a '68 (and I should start saying on mine anyway) , from the fuse mine goes to three, and only 3 places; the instr. cluster plug, the console guages [plug], and to the light on the heater bezel.
 

·
Registered
Joined
·
126 Posts
Discussion Starter #7
Yes it has 12V current i haven't checked the instr fuses yet I think that might be the problem though
 
1 - 7 of 7 Posts
Top