Team Camaro Tech banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hey guys,
I'm new to the site and was hoping to find some good info on here to help build by first circle track car. I live in Hawaii and our island has a small dirt track a group of guys has put together. I finally found a car I could afford to start tearing into. My mission is to get the engine and drivetrain in order according to the track regulations, then start on building a roll cage and other required items. The engine ID # is V032IEC. I'm pretty sure its a 327 and at first glance I can tell it has an Edelbrock performer intake, Edelbrock 4 bbl, and a Mallory ignition.

Here are the tracks regulations under the hood.

Manifold & Carburetor: any aluminum intake manifold and competition exhaust headers are required. No ram manifold or tunnels are allowed. One 2-barrel or one 4-barrel carburetor allowed. Max sixe is 750 cfm. 1 or 2 inch spacer allowed. No Superchargers or Webber carburetors allowed. No fuel injection.

Engine – Heads – Camshaft – Timing Chain & Gears: flat top pistons only, 360 cbi maximum required, no roller cams. Engine block must be cast iron and not aluminum. Heads must be cast iron only. No aluminum or angle plug heads allowed. Any hydraulic or solid camshaft is allowed. No rollers or mushroom lifters or roller cams allowed. Roller chain allowed. Gear drive is optional.

The track is very small in comparison to other dirt tracks that I've seen, so I belive low end acceleration will be key. I was able to get it running the other day for the first time and I think its having some valve issues. I hope to have it out and on a stand by weeks end if time allows.

Has anyone here built for a circle track before? I could really use some solid guidance.

http://www.paradisespeedwaymaui.com/
 

·
Registered
Joined
·
3,955 Posts
back in the 70s I run a 327 in a 68 Camaro with 12.5 -1 pistons. I run a solid lift cam(can't remember the lift)
bored .060 over with .030 cut off the heads and the intake cut to fit. run 5:38 gears with a 4 speed
the car would turn 7500 rpm
the first time it started it ran for about 3 minutes then started missing.
pulled the plugs and the electrode was mashed
we used index washers on the plugs to give us the clearance we needed
 
1 - 2 of 2 Posts
Top