Team Camaro Tech banner

1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
i have a 86 camaro Z28 with a 350 tpi
i am having trouble passing the emissions test here in texas. i have changed the oil, filter, plugs and wires,it has a new cat back exhaust and seems to run great. but i still acn't pass the test. help please...

------------------
 

·
Registered
Joined
·
10 Posts
Which part of the test does it fail. It could be EGR inop or stuck open, bad O2 you name it. What are the readings when it fails?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
it keepes failing the emissions portion. the limit is 220...1st test was 294. i changed the plugs wires and air filters and ran a valvoline fuel injector cleaner thru it. 2nd testwas 1410...it also has a new cat back exhaust(installed about a year ago - eventhough it has only gone about 400 miles since then)---also should i change the oil? it was changed about nine months ago but has only gone a couple hundred miles since then (the previous owner let it sit for the better part of the last year)does this sound like a bad o2 sensor? where is the egr located...and how do i check it?

------------------
'86 camaro Z28 350 TPI automatic
 

·
Registered
Joined
·
176 Posts
the 220 is the hydrocarbons limit and if you had 294 and put in new plugs and other tune-up items, it should have passed without the fuel injector cleaner. The BG products man told us not to try to run through the emmissions testing until we had run a complete tank of gas after the cleaner was used up in the present tank. What is the CO reading, you might need a new cat converter. Keep us posted on your results.

------------------
Leo Paugh
MCC #017
www.clark.net/pub/chevelle/mcc.htm
If you have no fear, you're not going as fast as you could.
 

·
Registered
Joined
·
1 Posts
I have seen HC readings rise drastically from using the injector cleaners unless you go through a tank or two of fuel. It is probably that. The EGR usually controls your nox and is probably operating normal. You definitely need to check O2 operation. Also check that the engine is getting to proper operating temp. Is the thermostat opening and closing? If the engine runs cold then the computer will commmand more fuel.
 

·
Registered
Joined
·
10 Posts
Is the Check Engine Light on?

the numbers you gave sound like HC. If the HC was in the 200's before and you put wires on it and now it is 1400's maybe one of the wires is not on right. Does it run rough since you put wires on it? If it runs good then maybe chalk the HC up to the Inj Cleaner.

What is the CO number and NOX? The EGR is probably not the problem however if it is open too soon, it can cause a missfire which will give you a very high HC reading.

Based on the original numbers I'd say it wasnt missfiring before. It may be a little rich but we cant tell without CO.

Are they placing your car on a dyno when they do the test?

Lurk
 

·
Banned
Joined
·
21,341 Posts
As funny as this sounds a new gas cap will cause a car to go from lean to rich because with a new cap all the gas vapors that normally got by the old cap from the carbon canister are now going into the engine and creating a rich condition where it was lean before. I saw it happen at an I/M station in St. Louis because the station manager knew what was happening and pointed it out to me and then took me aside and explained all the stuff.

The "Gateway Clean Air Program" has a pamplet that explains whats generally wrong if you want ta write them a letter and request a copy. Get on the web and find the "Gateway Clean Air Program's" home page and get hold of a guy by the name of Chuck Dachroedan, the head of the I/M section, (I think) and tell him my name and that I asked you to ask him for the literarture we are talking about.

I would be glad ta send you a copy of it but I'm in Jefferson City instead of St. Louis. Chuck is in the MO Dept.of Natural Resources St. louis Regional Office just off S. Lindberg and I-44. hope this is of interest. pdq67
 
1 - 9 of 9 Posts
Top