Team Camaro Tech banner

1 - 9 of 9 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
I'm a newbe to this forum. I'm a Corvette guy at present but I have had Camaros in the past. My reason for coming here is that I have a 67 Camaro 396 in my 68 Vette along with a 2004R tranny. My problem is at normal idle in park it runs fine. When I put it in gear it kills. The only way I can keep it from killing is to set the idle real high. I'm hoping someone in the Camaro community has some ideas for me. Thanks for any help !
 

·
Registered
Joined
·
2,291 Posts
Did you just recently place this setup in your car? I mean did you transplant this running 396/2004r into the vette? Please give some more info about this setup. Did you get the correct lockout convert?

Jeff G.
68 4-speed Vert
69 RS/SS 396 Vert
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
Thanks Jeff...Here is the only history of the car that I know for sure. The car had an M21 4spd in it when I got it. It was not a running car at the time. It sat for some years but nobody knows how many. The 396 was froze up when I got it. After a couple of weeks of turning a 1/4" each day with Marvel Mystery Oil in the cylinders I got it to turn all the way around. I then got it running & it seems to be OK...Compressionwise etc. Visually it appears to have been overhauled. By that I mean it has new main seals, oil pump, timing chain & gears. The valve springs appear to be new also. Everything I can see without tearing it down leads me to believe it was overhauled & never run The clutch & pressure plate on it were also brand new, never been spun. So, to your questions. I got the 2004R from a junk yard buddy of mine. I think it came from an 88 chevy caprice. I used the converter that was with the tranny. Today I tried a different Quadrajet that I had rebuilt & it seemed to go into gear & keep running without real high idle in park. It has'nt been on the road other than a few blocks around town. As far as a lock out kit I have'nt got to that yet. I'm looking at a kit from Painlees Performance Products for $168.00. I appreciate your input as I've never done anything like this before.
 

·
Registered
Joined
·
2,291 Posts
OK that gives us a lot more info for others to help you out. Yes you need this setup.

http://www.summitracing.com/parts/BMM-70248

I had a 700R in my Camaro so I'm a little familiar with this setup, there is also what appears to be a kickdown cable and this controls the shift points/line pressure, but the car should run though, may have to investigate more on that. It is another kit you need to purchase unless you have it came with the transmission.

Hope this helps a bit.
Jeff G.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #9
I don't think a 2004R has a vac hose. Does someone know for sure ? I know I don't have a vac hose going to it.
 
1 - 9 of 9 Posts
Top