Team Camaro Tech banner

1 - 17 of 17 Posts

·
Premium Member
Joined
·
901 Posts
Discussion Starter #1
This is my 1967 Camaro I bought 3 1/2 years ago. It came with the original 6cyl:thumbsup: and 2spd powerglide. Factory radio delete which seems odd. It now has a 454 stuffed under the hood backed by a th-400 trans. I bought it off the original owner. Came with the original bill of sale, 100,000 miles and a wee bit of rust.......which I am currently taking care of. Anyways, I am sure I will require a little bit of your help and suggestions along the way and will post more pics as I progress.
 

·
Premium Member
Joined
·
901 Posts
Discussion Starter #2
Sorry,......
 

·
Registered
Joined
·
336 Posts
Whew, sweet motor! Must be kind of scary with those drum brakes though.
 

·
Registered
Joined
·
355 Posts
looking good!
 

·
Registered
Joined
·
3,064 Posts
Good job! :thumbsup:
 

·
Premium Member
Joined
·
901 Posts
Discussion Starter #15
Is that a cover plate where the windshield wiper motor use to be?
No, Just a big hole......wiper motor wont clear my valve covers. Guess I will have to avoid the rain. Speaking of rain, its been raining for what seems months.....
 

·
Premium Member
Joined
·
367 Posts
Wiper motor could be remote mounted because you know it's going to pour rain for sure if you leave the motor out. LOL
 

·
Premium Member
Joined
·
901 Posts
Discussion Starter #17
Is there any aftermarket wiper motors out there that will mount with the tall valve covers???
 
1 - 17 of 17 Posts
Top