Team Camaro Tech banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
'99 Camaro
My front blinkers don't work and when I use my turn signal, the rear turn lights stay solid. When I turn on my flashers, the rear turn lights blink as they should. From what I can tell, the front turn lights are not burnt out. Any ideas on how I can fix the problem? My inspection sticker expires in April and I need to get this fixed.

Thanks for any advice,
Ryan
 

·
Premium Member
Joined
·
5,582 Posts
Try changing the directional flasher. The hazard flasher is fine based upon your post. Do the front lights flash also or only rears with the hazards on? If that is the case, try new bulbs after changing the flasher.

Kev
 

·
Registered
Joined
·
8,305 Posts
are the bulbs good?
how about the grounds?
corrosion in the sockets?
flashers could be bad.
 

·
Registered
Joined
·
295 Posts
I agree with kevin, derectional flasher.:yes:
 

·
Registered
Joined
·
2 Posts
Discussion Starter #6
Try changing the directional flasher. The hazard flasher is fine based upon your post. Do the front lights flash also or only rears with the hazards on? If that is the case, try new bulbs after changing the flasher.

Kev

The front lights don't flash when the hazards are on. I'll try changing the directional flasher. Should I be able to pick that up at any auto parts store?

I really appreciate everyone's help.

Best regards,
Ryan
 

·
Registered
Joined
·
1,295 Posts
Flasher more than likely, working at Advance Autoparts i see this alot.
 
1 - 8 of 8 Posts
Top