Team Camaro Tech banner

1 - 8 of 8 Posts

·
Registered
Joined
·
95 Posts
Discussion Starter #1
Hello everyone, Is there a trick to getting the front light harness unplugged from where it attatches to the firewall? I cannot budge it at all. There is a screw there but it dosn't look like it holds it in. Thanks!
 

·
Retired
Joined
·
16,027 Posts
the screw is very long and connects the center of the master harness connection. If that screw is backed out all the way, the plug itself could be rusted or gummed into place yet. Slowly pry with wide blade item like a thick putty knife and work it gently back and forth, it should loosen. Some WD40 wont hurt either.
 

·
Retired
Joined
·
16,027 Posts
yes the screw should back out all the way. I dont recall if its one of those kind that holds itself in place 'after' its released the threads but you wont loose it, so go for it. :)
 

·
Premium Member
Joined
·
22,122 Posts
I'm pretty sure it is the kind of screw that "stays in the hole" it needs to be completely unthreaded and will then just kinda "flop around"

I think the engine harness side needs to come off first, that would be the inboard half of the connector.

All this stuff was gooped up pretty well from the factory to prevent corrosion, some take a lil "breaking loose"
 

·
Premium Member
Joined
·
4,060 Posts
mine was sealed and was a bear to get off as i recall.
are you going to replace the harness?
make sure when you put it back together to use some RTV around the sealing surface of the plug to keep moisture out.
a dieclectric grease on the connections too!
 
1 - 8 of 8 Posts
Top