Team Camaro Tech banner

1 - 7 of 7 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Both of my front subframe aft attachment points are rotted and wallowed out. Will a subframe connector kit cover the affected area, or is there another fix other than replacing the subframe, or welding in a patch peice?
Fubarframe.jpg

Lhaftsubframe.jpg
 

·
Registered
Joined
·
7,794 Posts
Not that I am aware of. See the related post in Camaro tech.
 

·
Registered
Joined
·
1,463 Posts
Thats a common problem area. The rubber bushing holds water inbetween it and the frame and causes the rot. More of them are rotted there then not. They sell a kit to repair this but it might not cover all the area that you need. I would use 1/16" plate and fab up the area and use the correct sized holesaw to make the hole for the body mount.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Thanks for the posts, a yes the other areas have rot too. $1600 not including shipping for a new subframe eats into my engine rebuild and over drive tranny dreams thou. I have not found any repair kits, and I'm concerned that fab'in up a repair may cause hole misalignment, and that may cause other issues down the road.
 

·
Registered
Joined
·
1,810 Posts
There a couple subs for sale on ebay right now. $750 and $450. Another couple hundred and you could have them powdercoated at a nearby shop.
 

·
Registered
Joined
·
2,229 Posts
You can have a good welder patch that but like other's have said, being that bad I would worry about the rest of the frame's strength. If that's a TX car it must have been from near the coast.
 
1 - 7 of 7 Posts
Top