Team Camaro Tech banner

1 - 2 of 2 Posts

·
Registered
Joined
·
72 Posts
Discussion Starter #1
ok i have a 68 camaro that i put a 94 5.7 liter in . I have a new electric fuel pump that pushes 7 to 12 psi. The engine is 40 over w/ a big cam ,edelbrock performer intake @ a 600 edelbrock carb. Ok the car starts fine runs fine and everything and has done so all winter long.The other day it got about 80 deg outside. I went on a 2 mile run came back and let it sit and idle to see where the temp settled out at.The temp stayed around 205. I went to pull the car up put it in gear and it died on me. Got it to crank back up and i raised the hood and noticed that all the fuel in my fuel filter was shooting up the center of the filter and every once and awhile it would flash some in the outer glass part.By the way its a see thru fuel filter.Now when i first crank it up and the car is cold the fuel filter is full of gas but when it comes up to temp it does as said above and it starves the engine for gas. What can i do to correct this problem? Please any advise will be greatly appreciated.
 

·
Super Moderator
Joined
·
32,289 Posts
The fuel is vaporizing due to heat from the OE fuel line on the pass side of engine bay is next to the exhaust. Reroute it away.

You might consider running a return line back to the fill tube, that little piece behind the license plate is a good spot for hooking up a return line, and install a fuel regulator, ie., Holley type. Adjust the fuel for 6-7 psi, from the secondary side, one side to carb, the other secondary outlet to the tank.

This will keep the fuel cool.
 
1 - 2 of 2 Posts
Top