Team Camaro Tech banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
my husband has many toys including a 1991 sonoma with a 454 big block and so i got this bright idea to put a 1985 350 tpi in my 1985 s10 blazer. well we got everything hooked up (after working on it for 4 weekends) all day long.so we go to start it and it starts but then it dies after a second or two. please, i need my blazer, some one help me. i need to find out exactly what fuel pressure this motor needs and where i can find a fuel pump that will give the motor what it needs. thank you, betty lloyd
 

·
Premium Member
Joined
·
7,728 Posts
Betty -

What are you using now for a fuel pump? The TPI needs a high-pressure in-tank electric pump that maintains 35-40 psi at the injectors.

------------------
JohnZ
'69 Z28 Fathom Green
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
<BLOCKQUOTE>quote:</font><HR>Originally posted by JohnZ:
Betty -

What are you using now for a fuel pump? The TPI needs a high-pressure in-tank electric pump that maintains 35-40 psi at the injectors.

<HR></BLOCKQUOTE>
MY HUSBAND BOUGHT IT FROM CAR QUEST, HE BOUGHT A FUEL PRESSURE GAUGE AND HOOKED IT UP AND IT HAD 40PSI AND HE ADJUSTED IT AND NOW IT HAS 45PSI. IT IS AN IN LINE FUEL PUMP I DO KNOW THAT MUCH. WE HAVE EVERYTHING THAT WE NEEDED AND IT STILL WILL NOT START. WE ARE WONDERING IF WE NEED A VATS MODULE. WHEN WE BOUGHT THE WIRING HARNESS FROM JEGS THEY SAID WE DIDN'T NEED IT BUT THEN A GUY FROM PAINLESS WIRING SAID WE MAY NEED IT.
 
1 - 3 of 3 Posts
Top