Team Camaro Tech banner

1 - 14 of 14 Posts

·
Registered
67 Camaro L78 M20 Convertible
Joined
·
157 Posts
Discussion Starter · #1 ·
Hey guys i just recently observed this behaviour. This isnt normal, right?
All the gauges and interiour bulbs shut off when i switch from parking to headlights.
What could be the reason?
I didnt find a thread specifically regarding this behaviour..
 

·
Registered
67 Camaro L78 M20 Convertible
Joined
·
157 Posts
Discussion Starter · #3 ·
Ah i will look into that, thanks..

I wonder how it is grounded when its in parking light mode? Cause then it works.. hmm
 

·
Moderator
Joined
·
15,104 Posts
Check the headlight switch.

with the headlights on if you rotate the knob does the courtesy light turn on? Does turning the knob have any affect on the instrument lights?
 

·
Premium Member
Joined
·
5,532 Posts
I personally would be looking for hacked wiring. If wired as factory I would expect it to work in Headlight position the same as parking light regardless of grounds. It would be simple to check the ground while looking for the hacked wiring. I'm thinking the dash light gray wire hacked into the parking light wiring somehow.

Jeff
 

·
Premium Member
Joined
·
1,197 Posts
Going off memory here...

Doesn't the 67's park lights turn off when the headlights are on? If that's the case, could the instrument lights be tied into the park light circuit instead of the instrument lights circuit? (As Jeff said above). I think if you were to turn on the instrument lights and then pull the INST fuse the instrument lights should go out. If not they are on the wrong circuit.
 

·
Registered
Joined
·
123 Posts
I understand 67 & 68 park lights are not powered with the headlights on. UNLESS you wire it that way. On the 66 Corvairs I have, I did make the change with No wiring additions needed. Just move the purple wire in the headlight plug to the unused terminal on the headlight switch.

Here is the terminal breakout on the Corvair headlight switch. It should be the same on the Camaro.

275818
Chevy Headlight Switch circuits.jpg
 

·
Registered
Joined
·
34 Posts
First thing I would do is try a new headlight switch. They are cheap and its the least invasive thing to do. Also a likely suspect. If that doesnt work then start checking other items.
 

·
Registered
Joined
·
123 Posts
Take a look at the purple wire in the connector and it connection point on the switch. If not in the top left corner of the switch (as shown in the photo) you will not have park lights with headlights.
 

·
Registered
Joined
·
2,749 Posts
yes on a 67 parking lights go off with headlights on. No dash lights should not go out when headlights are on. If dash lights work with parking lights but not headlights....I would suspect headlight switch

I bought a AC Delco headlight switch for my 67 on rockauto...after 52 years the original was done
 

·
Registered
67 Camaro L78 M20 Convertible
Joined
·
157 Posts
Discussion Starter · #11 · (Edited)
Guys, thanks!
i will look into the switch and wiring first tomorrow..

The thing is the headlight switch is just a year or so old.. and before it worked flawlessly. All of a sudden it changed..
Hmm.. very short life span.. But i will check. Maybe its just a plug thats hanging loose or so..

It was a AC Delco D1588
ACDelco® D1588 - Genuine GM Parts™ Headlamp Switch

But on Rockauto i found a genuine GM one, is that of better quality?
More Information for GM GENUINE D1588

There is also another AC Delco:
More Information for ACDELCO D6251D

You guys know which one is the correct one?
 

·
Registered
67 Camaro L78 M20 Convertible
Joined
·
157 Posts
Discussion Starter · #12 ·
Check the headlight switch.

with the headlights on if you rotate the knob does the courtesy light turn on? Does turning the knob have any affect on the instrument lights?
If i remember correctly it does exactly that, but only in parking light mode... with headlights on gauge lights just go switch off, turning the switch had no effect anymore..

will check again tomorrow
 

·
Registered
Joined
·
112 Posts
I think the center upper screw for the dash/speedo insert is a ground. Mine fell out and caused strange issues. Just a thought.
 

·
Registered
Al - Waterloo, Iowa
Joined
·
4,694 Posts
Check the dash ground strap as Blitzer454 said and jimnecci mentioned. All kinds of weird stuff can happen if it's not making good contact or is even missing. The center upper screw on mine loosened. When the switch was pulled out, both turn signal indicator dash lights came on and the fuel gauge went past empty. Electricity takes the path of least resistance and can/will back feed causing things to run backwards and lights to illuminate when they shouldn't, etc. It takes less than 60 seconds and a phillips screwdriver to check the upper center screw. If yours isn't loose, remove the dash retaining screws to verify the strap is there.
 

Attachments

1 - 14 of 14 Posts
Top