Team Camaro Tech banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
95 Camaro 3.4L V6 Auto, 120000 miles

My service engine soon light comes on after about 15/20 minutes in the car (driving, not idling), usually after letting off the gas or just hitting the brakes.

I haven't been able to check out the code at Autozone since it has the OBD2 connector. Was wondering if the symptoms sound familiar to anyone here?
 

·
Registered
Joined
·
5,277 Posts
Sounds like the problem is occurring after the engine warms up enough for the ECM to enter closed-loop mode. Gonna have to get the codes to diagnose it much further.

Be sure to get the actual fault code and not the verbal description. My dad had an OBDII failure recently and AutoZone told him it was a "Secondary Emissions Failure". We'll there are no fewer that 1/2 dozen codes matching that description. Long story short, he ended up going back a 2nd time to get the codes.
 

·
Registered
Joined
·
2 Posts
i have the same problem... someone suggested several things to me...first being the ignition coil...but i can treally find out because OBD1 is so hard t ofind a scanner for you can jump the obd1 port to have the SES light flash and you just count the flashes to get the code
 

·
Registered
Joined
·
1,163 Posts
obd1 isnt hard to find a scanner for, or hard to scan!!!ofcourse, people with a REAL diagnostic tool will want to charge you for the use of their 2700 dollar investment...(thats what my birck cost from snap-on new)...global obd2 cars can be scanned fairly easily with a generic scanner, but that has huge limitations...theres no data stream on most budget obd2 scanners, and they dont have access to manufacturer specific codes...only generic ones with generic descriptions...anyway, your 95 is obd2 and autozone and a half dozen other parts stores can scan the car for you...keep in mind that these gentlemen and ladies do not have any formal training( usually) with diagnostics, so dont jump at their first recommendation as to what to fix first...but do take advantage of the free services offered...get the codeas and report back, and we can probably help...
 

·
Registered
Joined
·
2,292 Posts
95 Camaro 3.4L V6 Auto, 120000 miles

My service engine soon light comes on after about 15/20 minutes in the car (driving, not idling), usually after letting off the gas or just hitting the brakes.

I haven't been able to check out the code at Autozone since it has the OBD2 connector. Was wondering if the symptoms sound familiar to anyone here?
With out the DTC it is a long shot.Once you get it post it.The letting off the gas is a clue though.The pcm likes to test the EGR under these conditions and uses the map sensor to verify operation.9 out of 10 times the egr valve flow is suspect.Do not replace the valve right now.Pull the throttle body bellow and crack open the throttle blade.While viewing..look for a carbon buildup behind the throttle blade to the right side.The Egr tract can get coked up and needs cleaning.I use a flexible seat motor drive shaft in a drill to clean from the egr base to the throttle body.Pick the larger chunks out with a pick and soften the rest with carb clean.
 
1 - 7 of 7 Posts
Top