Team Camaro Tech banner

1 - 13 of 13 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hey folks, I've been registered here for a while but never post.
I mainly stay over at nastyz28.com with my '70, figured I'd say hi and show my ride off over here.

I bought this '70 in July '04, and started cutting rusty panels off.
I've done 100% of the work myself in my 2 car garage, paint, rewiring, all new poly bushings, new springs/suspension, interior, etc.
This is one of the very first second gens to roll off the line, the vin ends with 500030, so this is about as close to a first gen as you can get without actually being one :rolleyes:

Here's a couple pics:




I've had this car completely apart for paint:


And proof, painted in my 2 car attached garage:


I've had well over 20-25 Camaro's over the years, a few first gens along the way but I've become attached to the '70 - '73's.
 

·
Retired
Joined
·
16,008 Posts
Great pics, you did a good job on that car :)
 

·
Gold Lifetime Member
Joined
·
2,178 Posts
Welcome... I'm also from the NastyZ28 site....
 

·
Registered
Joined
·
3,064 Posts
Nice Job! Welcome to the Team! :waving:
 

·
Registered
Joined
·
7 Posts
Discussion Starter #13
Thanks everyone (the familiar and not-so)
I'm proud of this car, being able to say I built it from the ground up, in my little garage with limited budget, it's just cool to get compliments.

It's a work in progress, of course.
I built this one backwards from how I normally do.
Every other car I've had has been an 11 second car that looks like a POS. This one was so rough when I got it I had no choice but to get the body lined out first. It's still got the same stock small block that was in it when I bought the car. I'm in the process of getting a new healthy small block put together.

Thanks again fellas.
 
1 - 13 of 13 Posts
Top