Team Camaro Tech banner

1 - 4 of 4 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter #1
Hey Guys,
Maybe someone has had this problem and can give me some guidance. Ok here is the situation I have a new 383 Small Block with Edelbrock RPM heads that I just put into a 1967 Camaro, I am using Dougs D308 headers and I switched the motor mounts to Energy Suspension mounts here is a link

http://www.summitracing.com/parts/ENS-3-1114G/

Now I have the engine in and the headers install my drivers side header is hitting the floorboard. I guess not the header itself but the flange where you bolt up the reducers. I did my research on these mounts from this site and everyone said that they were the ones to use. Does anyone have any ideas on how to fix this problem maybe changing motor mounts or possibly headers. Any help appreciated.

Thanks
 

·
Premium Member
Joined
·
5,230 Posts
I would start by putting the stock GM mounts back in. Check to make sure you have the correct engine mounts and frame stands for your 327.
 

·
Premium Member
Joined
·
11,167 Posts
I have the same engine mount, D368 (1 3/4"tubes) headers on AFR heads, my flange is close , probably within ½".
First thing I would look at is your body mounts. If they are old and squashed, thats your problem. Since installing new subframe body bushings, my floor to header clearance increased.
 

·
Registered
Joined
·
1,748 Posts
Agree with Don. My headers hit the floor boards when my subframe bushings were squashed. With new body/subframe bushings, same motor mounts as you, but Hooker Headers I have just over 1/2" of clearance on the collector flanges.
 
1 - 4 of 4 Posts
Top