Team Camaro Tech banner

1 - 10 of 10 Posts

·
Registered
Joined
·
2,522 Posts
Discussion Starter #1
For some reason my headlights in my 68 camaro have stopped working. None of the fuses are blown, and I've replaced the switch with a brand new one. Still I get nothing when I turn them on. :eek:

Checked all the wring and everything seems to be intact.

Need Advice...Any and all suggestions will be greatly appreciated?
 

·
Registered
Joined
·
2,522 Posts
Discussion Starter #6
Checked the fuses, but not the dimmer. Will check that when I go back out there. Thanks!
 

·
Gold Lifetime Member
Joined
·
2,189 Posts
I'll bet it's the dimmer. Those things always seem to have problems.
 

·
Registered
Joined
·
2,522 Posts
Discussion Starter #9
I FINALLY got this car out of garage, and you guys were dead right. The switch was completely broken! :eek:

I have absolutely no idea how this happened, but the wire contact part was completely broken off from the rest of the switch. I bought a new switch for 5$, bolted it in, and "POOF" the lights came on.

Thanks for the help guys. You all are the greatest :cool:
 

·
Premium Member
Joined
·
1,149 Posts
I FINALLY got this car out of garage, and you guys were dead right. The switch was completely broken! :eek:

I have absolutely no idea how this happened, but the wire contact part was completely broken off from the rest of the switch. I bought a new switch for 5$, bolted it in, and "POOF" the lights came on.

Thanks for the help guys. You all are the greatest :cool:
Good job!

Just for reference, the headlights aren't protected by the fuses. The headlight switch has an internal circuit breaker. If there is an overload you won't be stuck with totally inop lights, just intermittent.
 
1 - 10 of 10 Posts
Top