Team Camaro Tech banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 95 Z28 58,000 miles. The problem
I having is when The car is Idling the temperature gage goes up to around 210 and the fans do not come on. If I turn on the air conditioner or defrost the fans will come on and the temperature goes down. Since the fans work or at least one fan works, I assume it is not the fans. I have checked the fuses and relays and the are okay.Since the fans only work with the air conditioner is there any other sensors or swithes I should check. I would appreciate any advice.
P.s. thats for the advice with leaking remain seal.
 

·
Gold Lifetime Member
Joined
·
10,443 Posts
Usually whenever the a/c is turned on the power is run through a relay and automatically turns on the fans regardless of engine temp. This prevents the head pressure at the compressor from getting too high. Otherwise either a separate temp switch or the computer through the engine temp sensor controls the fan. I believe the computer controls it on your car. Often they aren't set to come on until 215-220 degrees so there may be no problem with yours at all. The aftermarket tuners that re-program your ecu can change the temp that it comes on at.

Jody
 

·
Registered
Joined
·
94 Posts
i have a 94 and the guage goes up to 215 before the fan comes on. you can buy the lower temp switch for about $38.69 the part number is jet-60600 it turns on at 200 and shuts off at 185.
 
1 - 3 of 3 Posts
Top