Team Camaro Tech banner

1 - 14 of 14 Posts

·
Registered
Joined
·
1,187 Posts
Discussion Starter #1
My first day. Had a 69 in HS. Kept it 12 years and sold it 12 years ago! I didn't want it to rust, and had no garage for it. Didn't realize it would appreciate 400% even if it rusted! Bought the second one on March 5th, and it's not getting away. A 69 sport coupe with 327 and 4speed in original hugger orange w/ black hockey stripe. Starting the resto!
 

·
Registered
Joined
·
1,187 Posts
Discussion Starter #6
Joe: where bouts in Okla? I'm visiting my mom in Edmond. I live in Calif. I have looked at 2 cars since I've been here, not that there aren't enough cars in Los Angeles to look at. I'm still shopping around for one.
I am in Norman. Good luck on the Z-28 that is a tough one.
 

·
Registered
Joined
·
3,893 Posts
Joe: if you'r wanting to take it for a good test drive, drive it up to Edmond! would love to see it! we could cruise the Sonic. on that note.... went to McLoud (my home town) was talking to the manager, he says kids don't drive around there like we used. we'd sit there every Fri or Sat nite and have fun. I guess kids are too sitting in front of their computers or hanging out at Starbucks (not that McLoud would have a Starbucks!) would love to see that car.
 

·
Registered
Joined
·
1,187 Posts
Discussion Starter #9
Joe: if you'r wanting to take it for a good test drive, drive it up to Edmond! would love to see it! we could cruise the Sonic. on that note.... went to McLoud (my home town) was talking to the manager, he says kids don't drive around there like we used. we'd sit there every Fri or Sat nite and have fun. I guess kids are too sitting in front of their computers or hanging out at Starbucks (not that McLoud would have a Starbucks!) would love to see that car.
Actually, I have to pull the resto first. Motor has a spun rod I would suspect. Block is OK as far as I can tell. Motor had 225,000 which is alot for one of those. Will probably put my other motor in it and save the original.
 

·
Registered
Joined
·
1,187 Posts
Discussion Starter #10
Took the motor apart. It is not blown. It had a broken valve spring on 5. I guess he thought it was done. There is some corrosion in 7. It sat since 93, maybe condensation was drippin back into 7? It has 225,000 miles and I bet this thing doesn't have .005 wear in the cylinders. 7 looks like it would hone out....
 

·
Registered
Joined
·
202 Posts
Joe, welcome to a great camaro site. I think you'll enjoy it.

Dee
 

·
Premium Member
Joined
·
6,360 Posts
Hey fellow OKIE!!! Glad to have you!
Hey I lived in Newalla for a few years. McCloud was the school my kids went to. Never saw the kids hangin at the Sonic tho. Sux. I did that in my hometwon of Altus.

"Another Camaro Saved"
 
1 - 14 of 14 Posts
Top