Team Camaro Tech banner
1 - 11 of 11 Posts

·
Registered
Joined
·
2,803 Posts
Discussion Starter · #1 ·
1968 camaro... i just installed my engine and tranny...small block m21 trans. the clutch fork hits the firewall!!!!!

i have all stock stuff.
diaphram type press plate,
the correct fork i think. are they any different ones?
small block clutch linkage.





do 1968 camaros use the long throwout bearing? mine has the short one.....this all came with the clutch kit
 

·
Registered
Joined
·
189 Posts
If you can't find a GM fork, you could also probably remedy it by using an adjustable pivot ball in the bellhousing. They're $16 from Summit / JEGS
 

·
Premium Member
Joined
·
5,582 Posts
Wagonman...

Is the engine and transmission in place on the mounts without being jacked up? I remember doing a changeover for a friend and the fork hit, I let the transmission and motor down and it was fine. Its not to say you have the wrong fork or pivit ball....as others have suggested.

Kev
 

·
Premium Member
Joined
·
3,327 Posts
wrong T/O bearing.........went thru this last year, There is a tall and short one and sounds like you have the short one.
 

·
Premium Member
Joined
·
3,327 Posts
Just reread your post. So you do have short, this takes to much of a throw to engage pressure plate allowing the fork to hit.....the taller one takes much less movement to engage the PP and therefore doesn't allow the fork to hit the firewall. I learned the hard way also but my I can have trans out in an hour now!!
 

·
Registered
Joined
·
16 Posts
Would the short T/O brg cause the trans to not go into gear all together? My clutch fork does also hit the body but I can't even get he darn thing into gear with the engine running. The trans was purchased as "known good"; beyond that I don't have much other info. Do you think the T/O brg is the culprit or should I also suspect interna trans issues? Thanks for your help.
 

·
Registered
Joined
·
16 Posts
Trans NO-GO

Would the short T/O brg cause the trans to not go into gear all together? My clutch fork does also hit the body but I can't even get he darn thing into gear with the engine running. The trans was purchased as "known good"; beyond that I don't have much other info. Do you think the T/O brg is the culprit or should I also suspect internal trans issues? Thanks for your help. :confused:
 

·
Registered
Joined
·
610 Posts
The correct clutch fork is still avaible from GM do a search on my name & it will show a post in this section that has all the current part #'s for the clutch fork & some other needed parts. they are a lot cheaper than going thru a Camaro supply store. Johnny
 

·
Premium Member
Joined
·
3,327 Posts
Re: Trans NO-GO

Would the short T/O brg cause the trans to not go into gear all together? My clutch fork does also hit the body but I can't even get he darn thing into gear with the engine running. The trans was purchased as "known good"; beyond that I don't have much other info. Do you think the T/O brg is the culprit or should I also suspect internal trans issues? Thanks for your help. :confused:
Did you install a new clutch or when did your problem start?
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top