Team Camaro Tech banner

1 - 4 of 4 Posts

·
Registered
Joined
·
116 Posts
Discussion Starter #1
I have a 69 w/ multileaf leaf springs, and the offset shocks. The car had traction bars on it when I got it. I wanted to get rid of the traction bars so I bought a set of replacement shock brackets from NPD and a set of KYB gas shocks.

Problems / questions

1. The left side bracket bolts up no problem. The right side has a tab that the lower shock mounts to that angles back, not forward. So when the top of the shock is mounted it caused the bottom to not sit flush against the bracket. The Left side is perfect.

2. The right side didn't have a rubber cushion between the shock bracket and the springs. The left side did have one as part of the traction bars but I didn't put it back on. Do I need the cushion on both the left and right or neither.

3. Does anyone know what the torque secs are for the lower shock bolts

4. Does anyone have the torque specs for the shock brackets Ubolts

I am not sure if when the car is taken off the jack stands that it will settle in or do I have something on wrong.

Please help..... You always do
 

·
Registered
Joined
·
116 Posts
Discussion Starter #3
Yeah Jim, that's what I understood when I both the brackets from NPD. It was the same part number for both sides.. But the tabs that the lower shock bolts to has a slight angle backwards.... so when the shock has to lean forward to catch that top mounting hole it creates and odd angle and the mounting isn't flush. I know I am not explaining this well..
 
1 - 4 of 4 Posts
Top