Team Camaro Tech banner
1 - 5 of 5 Posts

·
Registered
Joined
·
23 Posts
There is no quick test for your problem. The main power supply from the circuit breaker should be checked. Each relay can be tested for coil operation, contacts should be checked within the relay for burning or pitting. ( Three relays total ). There are limit switches on the head light doors. They should be checked for operation, ( make and brake circuit ). All ground conections should be looked at, check for broken wires or corrosion. All wire connections should be checked for the same. Check the head light motors them selves for operation. The factory motors could be sized. A little information, the after market door motors are heaver built then the factory, better gear reduction for operation. Good luck.
 

·
Registered
Joined
·
2 Posts
I have just completed a complete restoration on a 67 and the headlight doors and electrical system are giving me fits. New harness and all components are new. The system has worked correctly a few times but every time I turn on the ignition a different scenario occurs. Now it seems to work backwards,ie you can close the doors manually and when you start the car the doors open and when you turn on the lights the main circut breaker for the doors pops. At first they opened correctly but the doors wouldnt close when the lights were turned off. After walking away out of frustration I returned to find the horn not working, tail lights staying on and the parking brake light in the dash was lit. WIERD!!!!! Any suggestions????
 
1 - 5 of 5 Posts
Top