Team Camaro Tech banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I've just completely re-wiring a 1967 Camaro so that I could get it inspected. I've hooked up the horn and as soon as I connect the battery cable the horn blows without pushing on the horn button. When I take apart the horn button, remove the plastic ring as described in http://books.google.com/books?id=MpEcKLD_L20C&pg=PA105&lpg=PA105&dq=1967+camaro+horn+hook+up&source=bl&ots=lfpRZGXxMx&sig=XMsd-iNWdoMwbmGH7L3PaPhsYMs&hl=en&ei=0F5KSovlD4LGlAfVzowr&sa=X&oi=book_result&ct=result&resnum=2 It appears all is installed correctly. If I leave the horn torn apart at the steering column and connect the battery cable it does not the horn does not blow, so I believe that my problem is at the horn connection. One other strange thing to me is that there is not type of spring loading of the button, seems to me that it should have some return action. Anyone with a solution or suggestion?

Bill
 

·
Registered
Joined
·
283 Posts
Bill it's been a while for me but if you look at the spring washer in the third pic I think it has a slight curve built into it. You might have that on backwards or upside down. Just flip it over and try that. Maybe someone who has done it recently will chime in but at least it's a start.

John
 

·
Registered
Joined
·
76 Posts
The black spring washer should curve towards the steering column. If he installed it wrong, the horn wouldn't work at all (I believe).

Look at picture 8. The button should have a spring, and should also reside in a plastic washer-tube thing (As you can see from the pic). The plastic keeps the button from touching the steering wheel which creates a short causing the horn to sound.

You say you don't have a spring holding the button? Do you have the plastic tube that sits on a big plastic washer under the steering wheel? The plastic tube should fit through a hole in the steering wheel so the metal button doesn't touch the steering wheel itself and possibly create a short.

You have both plastic rings? The white one that goes in first, that the black spring washer sits on? And you also have the red plastic ring that goes into the center cap retainer?

Those are my guesses for now. Can you take some pictures of the parts you have and how you have it installed?
 
1 - 4 of 4 Posts
Top