Team Camaro Tech banner

1 - 6 of 6 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
I don't know if I in the right section. But here is my problem.
I replaced the aftermarket steering wheel with the orginal standard wheel (69 camaro). I think I have everything I needed to do this, but what it is doing is when I push the key in the ignition the horn goes off. but it will not sound by using the horn buttons. Any help out there?
 

·
Premium Member
Joined
·
5,325 Posts
dgr, check to make sure your horn wire is not grounded to the steering column or if the horn button is bad, sounds like maybe the wire is grounded, but it would sound off even with the key out?!...did you do any other wiring at the same time? If so, that could be your problem. good luck...Mike
 

·
Banned
Joined
·
33 Posts
MAKE SURE YOU HAVE A CONTANT "HOT RED WIRE" THAT IS ALWAYS HOT THE BLACK WIRE GOES TO THE RELAY ALONG WITH THE RED, DOUBLE CHECK THIS, IT SOUNDS TO ME IF IT ONLY WORKS WHEN YOU TURN THE KEY ON THEN THIS RED WIRE IS NOT ALWAYS HOT, LIKE THE PREVIOUS PERSON SAID, YOUR HORN SHOULD HONK EVEN WHEN KEY IS IN THE OFF POSITION. ITS ONLY 2 WIRES. SO MAKE SURE YOUR CONNECTIONS ARE CORRECT AND WHEN YOU PUT THE CAP ON IT ISNT GROUNDING OUT ON YOU AS WELL, PLEZZ DONT MAKE THE MISTAKE I DID WITH MY CAMARO AND CHANGE THE WHEEL FOR A PEP BOYS SMALL WHEEL U KNOW THE KIND U CAN DRIVE WITH HAND CUFFS ON??


[This message has been edited by knightmoose2000 (edited 09-01-2002).]
 

·
Registered
Joined
·
500 Posts
The 69's had two small wires on the horn relay which is on the passenger's side radiator support. One was for the horn button, the other was for the "key in" buzzer(also in the horn relay). Sounds like they're mixed up. There are three spade terminals on the relay. Green 12 gauge wire goes to the horn. Try switching the other two.

------------------
'69 RS Camaro
355 5-speed 4.11
 

·
Registered
Joined
·
11 Posts
Discussion Starter #5
Thanks Guys! The kid I got my camaro from did a lot of silly things. He could have got the wire cross. I will try that.
 

·
Registered
Joined
·
119 Posts
lol sounds like i got my camaro from the same kid, i have all sorts of wierd wiring probs.
 
1 - 6 of 6 Posts
Top