Team Camaro Tech banner

21 - 40 of 54 Posts

·
Registered
Joined
·
434 Posts
Discussion Starter · #22 ·
Thanks for the Pics man. I actually Ordered my Setup Yesterday. Was a scramble as they sold out yesterday afternoon right before I tried to buy it. I was able to get a unit from summit who had them in stock still. Lets hope I dont regret this purchase! Its gota be better than what I got now lol
 

·
Premium Member
68 Camaro SS/RS, 454 BB 4 speed, 3.73 Posi, new paint, motor mods , trans and diff assembly. 2" Drop
Joined
·
309 Posts
Sure thing. If you need a better pic, I can take some close ups. My engine is out and I could get better shots. Be sure to get the inline filter, their ad says you need this for the lifetime warranty on the unit. I won't have a vacuum issue when I put the recammed motor back in, but since its there Ill leave it incase I want to get more aggressive with another cam in the future.
 

·
Registered
Joined
·
434 Posts
Discussion Starter · #24 ·
Yes, I ordered the filter also. It seems like cheep insurance =)
 

·
Registered
Joined
·
182 Posts
You will love it.
I don't have a filter on mine, never thought of it. If it dies I will be going to manual brakes though. I want to simplify all of it.
 

·
Registered
Joined
·
434 Posts
Discussion Starter · #26 ·

·
Registered
Joined
·
182 Posts
SO I thought I was good but I am having 2nd thoughts about my pump. I am thinking why not replace it just to be on the safe side? Was looking around and found this pump.
Borgeson Universal Company :: Pumps, Brackets, Hoses & Adapters :: Self Contained Power Steering Pumps & Brackets :: P/S Pump, for Hydro-Boost Brake Applications
Would that be the correct pump for my application? Just wondering - its Sunday so I cant call them to ask lol
Mine is a stock pump with different valve
Driving it yesterday it'll lock the brakes up no problem
 

·
Premium Member
68 Camaro SS/RS, 454 BB 4 speed, 3.73 Posi, new paint, motor mods , trans and diff assembly. 2" Drop
Joined
·
309 Posts
Mine is a weird pump, it has a remote reservoir mounted alongside the radiator and has like a 1"+ hose going to pump. In your pic it looks like the snout will take the pressed in pully VS the Saginaw with the keyed shaft and nut.
 

·
Registered
Joined
·
434 Posts
Discussion Starter · #29 ·
not sure how to differentiate - I think its a press on but it for sure has a Nut? How do I know?
273815
 

·
Premium Member
68 Camaro SS/RS, 454 BB 4 speed, 3.73 Posi, new paint, motor mods , trans and diff assembly. 2" Drop
Joined
·
309 Posts
Thats a keyed shaft. The press on type doesnt have a threaded hole in shaft for a bolt. This takes a special puller/installer.
 

·
Registered
Joined
·
434 Posts
Discussion Starter · #31 ·
Thats a keyed shaft. The press on type doesnt have a threaded hole in shaft for a bolt. This takes a special puller/installer.
Thanks, I just called Borgeson and they Told me the same thing. Now I need to find a different pump =)
 

·
Registered
Joined
·
434 Posts
Discussion Starter · #32 ·
SO Borgeson dose not make one for my application and I called summit and they also dont have one in stock for my application by anyone. I am still looking, gona call a few manufacturers but I am stumped right this moment
 

·
Registered
Joined
·
434 Posts
Discussion Starter · #33 ·
SO Borgeson dose not make one for my application and I called summit and they also dont have one in stock for my application by anyone. I am still looking, gona call a few manufacturers but I am stumped right this moment

PS - CPP make something just for this =).
&
 

·
Registered
Joined
·
434 Posts
Discussion Starter · #34 ·
Well the saga continues. I am posting this just for Information as it may help someone someday. SO I test fitted the CCP Hydroboost system today and Guess what, It wont work for me. One of the fittings for the Lines comes out about 3/4" from my headers tube. I do have very large primary tubes but still, there is NO way I am getting a line on that fitting. The thing that stops me from using it its how the mountiung bracket is part of the Main Body. The CCP system dose change the angle of the unit so the MC will be more level in the car. Problem is that new angel moved everything closer to my headers. SO now - Looks like I Need to return this and try the POL system. If the POL system positions itself to close to the header also - I will chop and weld on the bracket to give myself more clearance. I do hope that's not needed though. The systems do seem to be designed a little different - we will see how it goes. This is par for the course. Not sure how you guys make out but it always takes me several attempts to get stuff worked out. Its Never one and done for me
 

·
Registered
Joined
·
182 Posts
Well the saga continues. I am posting this just for Information as it may help someone someday. SO I test fitted the CCP Hydroboost system today and Guess what, It wont work for me. One of the fittings for the Lines comes out about 3/4" from my headers tube. I do have very large primary tubes but still, there is NO way I am getting a line on that fitting. The thing that stops me from using it its how the mountiung bracket is part of the Main Body. The CCP system dose change the angle of the unit so the MC will be more level in the car. Problem is that new angel moved everything closer to my headers. SO now - Looks like I Need to return this and try the POL system. If the POL system positions itself to close to the header also - I will chop and weld on the bracket to give myself more clearance. I do hope that's not needed though. The systems do seem to be designed a little different - we will see how it goes. This is par for the course. Not sure how you guys make out but it always takes me several attempts to get stuff worked out. Its Never one and done for me
Shouldn't be needed with Pol since it's not flipped over like the cpp one of memory serves me
 

·
Registered
Joined
·
434 Posts
Discussion Starter · #36 ·
I hope that's the case. I went back and forth between the 2 and well, I chose poorly =/
 

·
Moderator
Joined
·
15,100 Posts
I believe you were cautioned not to use CPP?
 

·
Registered
Joined
·
434 Posts
Discussion Starter · #38 ·
I believe you were cautioned not to use CPP?
I was - And I asked for more Information. I even sent private messages asking for more information but I did not get a response. I was getting information saying CPP was great also! If I had a Small Block it probably would be fine. I made a choice based off the Information that I had available to me. All I can do is the best I can do with my limited experience
.
 

·
Moderator
Joined
·
15,100 Posts
Best of luck. All’s good. That why we call it hotrodding.

My issue with CPP is very limited technical support. Majority of product seems to be Chinese import. Not always bad but potential for disappointment is relatively high.

Hopefully the pol works better. I still like the electric unit but I understand it’s more costly. That said sometimes the extra cost it worth the price in the long run.
 

·
Registered
Joined
·
434 Posts
Discussion Starter · #40 ·
POL is Back-ordered for a Month. Waiting on Wilwood or so they say.



Now we wait 🤬
 
21 - 40 of 54 Posts
Top