Team Camaro Tech banner

1 - 12 of 12 Posts

·
Registered
Joined
·
76 Posts
Discussion Starter #1
Ok, I'm about to lose it. I returned from Reno for Hot August Nights park the car in the garage. Go out a few days later to head over to Niles Car Show and BAM, she wont idle! It doesn't start right away, once the engine warms up. I have an 69 Z/28 completely stock! The car will idle for about a minute or so, then slowly choke itself off untill it stalls. Sometimes it will idle a little high then drop down to normal, stumble a few times then stall. This is what I"ve done so far, Replaced inline fuel filter,fuel pump, had the carb. gone through and flow checked. I've played around with the adjustment screws on the carb, the timing, nothing seems to affect it. I've checked for vacuum leaks around the carb, intake and head area, but it doesn't want to idle very long to get a good check. I dought thats it??????? I've also had a friend take a look, no dice. Fixed alot and had it idle a little longer but no fix. Any help or sugestions would be greatly appreciated. If more engine ifno is need: it's the DZ 302, 30/30 cam, 1178 crank, DZ carb, Z intake. I'm running a stock looking distributor, with HEI unit internals. Hope this help. And thanks again.

If it's not a crummy day, then it just isn't worth getting out of bed!
Mr. G

------------------
Jess - Camaros Limited Nor-Cal
69 Z/28 Lemans Blue
 

·
Retired
Joined
·
26,665 Posts
I can elaborate some. Timing is steady with initial at 10 degs btdc, dist was curved to run with 12 initial but the engine seems to like 2 degs less total. Carb was put on a 327 and the guy going through it said it was fine after replacing the floats. He said they had colaspsed. I think we were getting 7" of vacuum at 900rpm, richening up the idle mixture past 1 1/4 turn doesn't seem to make a difference, carb responds to changes when leaning it from there.

Carb is vacuum sec 780 (DZ carb) As jess said he had a carb shop go through it. I was gonna look into the primary butterfly adjustment and other basics but figured the carb guy would have taken care of the adjustments.

------------------
...Dennis
"The '69, the '96 & the club"
 

·
Registered
Joined
·
500 Posts
At the very least I would take the site plugs out and check the float levels. If it had phenolic floats there might be some junk clogging something. When these things break down enough to sink they usually leave something behind. If the car backfired at all you might want to check the power valve. I don't now how thorough your carb guy is is but the power valve is often overlooked.

------------------
'69 RS Camaro
355 5-speed 4.11
 

·
Registered
Joined
·
1,663 Posts
Maybe the gas tank sock is covered in gunk and fully clogging after the engine idles for a few minutes.
 

·
Retired
Joined
·
26,665 Posts
I set the primary float and then the carb later went to the specialist. I would expect it to be properly adjusted but these days you never know!!

Gene - If the sock in the tank were cruddy could it still flow enough to not be a problem at higher rpm? I kinda had the sock in mind but on a test drive with jess it didn't searge holding the speed steady. Keep those ideas flowing, I know Jess is real frustrated by this one.

Jess - if he doesn't hit you up for more money maybe you should let the carb guy see it in action...

------------------
...Dennis
"The '69, the '96 & the club"
 

·
Registered
Joined
·
76 Posts
Discussion Starter #6
The carb, was completely gone through. The seats were replaced, pwr valve and he ran it through a sonic cleaner? I spoke with the carb. guy today, he said he set eveything back, that all I should do is set the idle screws. I'll double check everything tomorrow. Thanks for the ideas guys. Keep em comin.It runs great at all speeds, just no idle???
DJD - I ran it to day. This is the second tank since Reno. It idled like yesterday in front of your house then slowly choked itself off. What's a gas tank sock?
If I still don't have a clue?? by Monday I'll take her down to the carb guy. He seems down to earth. He know Vic, which is who recommended him.

Workin in a mine all day with six other dwarfs, were's the fun in that.
Mr. G



------------------
Jess - Camaros Limited Nor-Cal
69 Z/28 Lemans Blue
 

·
Registered
Joined
·
76 Posts
Discussion Starter #7
Well, took the car out today and got it nice and warm. It would idle around 900 rpm somtimes then I would take off at a light and then be at 1500 rpm at the next light. I let it idle for 10 minutes at 900 rpm and it would jump to 1500 or so on it's own then come back down? No stalls, no adjustments? Do valves stick? Any ideas? Anyone?
I was at a little show today, and was asking around. Got a lot of direction back toward the carb??

Back to the mine.
Thanks,
Mr. G

------------------
Jess - Camaros Limited Nor-Cal
69 Z/28 Lemans Blue
 

·
Registered
Joined
·
2,372 Posts
I have a 302 and had the same issues. I recurved the distributor and blocked the heat riser passage on the drivers side, installed a restrictor insert in the other side of the intake gasket and set up the vacuum advance to manifold vacuum and the problem was solved. Basicaly I had a fuel percolation problem and the recurve allowed me to run more initial without increasing the total advance. This reduced the operating temperature. The manifold vacuum also helps to reduce temps at idle. The mixture screw adjustment is critical. I would also pull the spark plugs and give them a look see. There are lots of clues to be found by reading the plugs.

-Mark.
 

·
Registered
Joined
·
76 Posts
Discussion Starter #9
Just wanted to drop you guys an update on the idling problem. With lots of help from Dennis and Dave it was narrowed down that the distributor needs a small adjustment. I removed the new distributor and put the old/ original one back in to test the theory. I idled the car for 20 minutes. She idled just fine, a little variation in the idle but not much. Went for a drive yesterday in the car, idled just fine in and out of traffic. I guess the new distributor would let the timing drop down as the idle dropped down, causing the car to surge at idle???? I think this is correct. DJD correct me if I'm wrong here. Thanks for all the responces and ideas. Thanks DJD for helping out when you should have been getting your car ready for San Diego. Thanks Dave for all the tech support with the distributor.


Mr. G

------------------
Jess - Camaros Limited Nor-Cal
69 Z/28 Lemans Blue
 

·
Moderator
Joined
·
10,153 Posts
I guess you are not running a true large body type HEI.
The HEI is very easy to hang the adavance weights on. The kit springs are very very soft and often you need to use the softest springs to get the advance to come in full by 2500 rpm's. The weights are very light and are usually shaped wrong (finger end too long) and require a lot of effort to make them work right.
Evem the older style distributors can have sticking problems, especially with the softest adavance springs.
With all the secondary voltage arcing around inside the cap, the adavance mechanism will eventually rust, and I have seen several freeze up and not adavance from rust between the main shaft and "pole piece".
Also on any chev distributor, the rotor can limit weight travel if the weights are shaped a bit wrong. You will then have less total advance with the rotor on than with it off.

This all should be set up on a distributor machine with rotor installed, to be sure you get a smooth action out of the mechanical advance.
It is also a good idea to veryify the diaphragm is OK in your vaccum adavance.

I was going to suggest trying a new set of plugs in the engine. Often you can get into trouble fiddling with the distributor and carb when in reality it is the plugs or ign wires that are bad.
I was taught in auto shop, you need to be sure you have a good electrial foundation before tuning on the carb.

David

------------------
Check my web page for First Gen Camaro suspension info:
David's Motorsports page
First Gen Suspension Page
67 RS 327 original owner. 69 Camaro Vintage Racer, 65 Lola T-70 Chev SB Can-Am Vintage Racer

[This message has been edited by davidpozzi (edited 09-01-2002).]

[This message has been edited by davidpozzi (edited 09-01-2002).]
 

·
Registered
Joined
·
2,372 Posts
Idling "on the cuve" sounds like it could be the problem. You can verify it by swapping in some stiffer advance springs and see if the problem goes away. Another way is to reduce the idle speed below the factory spec and watch with a timing light to see if the advance backs off bellow the idle spec as the RPM goes down. If it does, you are idling "on the curve" and will not have a stable idle. The solution is to run a thicker advance bushing or reduce the cenrifugal advance slot in the autocam plate so it can not back down any further than the idle spec. You want the centrifugal to start just above the idle RPM, not below it. As David said, you should check the vacuum advance canister if it is set up to use manifold vaccum instead of ported advance. If you are using ported advance, this is not the issue.

-Mark.
 

·
Premium Member
Joined
·
7,728 Posts
Ported spark contributes to this problem, especially on a stock Z/28; there is no vacuum advance (stock) at idle, so idle stability is solely determined by the point where centrifugal advance starts - if you're just "into the curve" at idle, it will vary as the weights dance in and out against too-soft springs and the idle will fluctuate.

The cure for this (as Mark and I have both done) is to replace the original vacuum advance can with an Echlin VC-1810, which pulls in completely at 8" Hg. vacuum and adds 16* (crank) of advance at idle (you'll be lucky to get 10" Hg. at 900-950 rpm anyway, and the stock can still won't be operating), and tee it into the vacuum hose to the choke pulloff (or the fitting on the manifold behind the carb), both of which see full manifold vacuum. This added advance at idle (with the can fully-deployed) will both smooth out and stabilize the idle, reduce idle operating temperature, and improve off-idle throttle response. I run mine with 8* initial and 24* in the distributor, and it runs great (on pump premium).

------------------
JohnZ
CRG
'69 Z28 Fathom Green
 
1 - 12 of 12 Posts
Top