Team Camaro Tech banner

1 - 5 of 5 Posts

·
Premium Member
Joined
·
10,080 Posts
Discussion Starter #1
My starter motor keeps running after the car starts and will only shut off when I pull the battery cable. :confused: I changed the starter solenoid but this did not cure the problem. I think that the ignition switch is bad. Does the column have to come out to change the switch? Evidently the contacts are in the column and the switch is on top of the column. Thanks,
Gary
 

·
Premium Member
Joined
·
10,080 Posts
Discussion Starter #2
Any one?
 

·
Registered
Joined
·
1,657 Posts
Hi Gary,
If it is the switch you don't have to pull the column, just the steering wheel. Then a hole has to be drilled in the column housing so you can access a small spot on the switch that needs to be pushed in as the key is turned to a certain position. (can't remember the exact position)The switch will then come out.
Doug
 

·
Premium Member
Joined
·
10,080 Posts
Discussion Starter #4
Well you know what. It was the purple and yellow wires on the starter solenoid that had slightly melted together due to hanging next to the headers. You know the ones I am talking about,heh Doug. ;) One of those things that I planned on fixing when the engine is replaced. I'm a happy guy now 'cause I can drive it!
Gary L
 

·
Registered
Joined
·
1,657 Posts
Ignition switch-key cylinder? Heck there all in the same area, right? :confused:
I'm helping, I'm helping

Glad you got it figured out Gary, enjoy!!
Doug
 
1 - 5 of 5 Posts
Top