Team Camaro Tech banner

1 - 8 of 8 Posts

·
Registered
Joined
·
482 Posts
Discussion Starter #1
Just thought I'd bounce this off you guys.

When I go to start my camaro, I hear a clicking noise. So I remove the negative cable from the battery and clean the terminals. I reattach the cable on the camaro starts.

If this were an issue with a dirty post though, it would only happen once. However, I'll have to repeat this procedure in the same day. Go figure cause I know the post is already clean.

I haven't done any troubleshooting on it yet but I thought I'd check here first.

Let me know what you think.

Dave Jurek
 

·
Registered
Joined
·
130 Posts
Are you using the original style battery cables that are the spring loaded type that has no bolt? I was having that same problem with my car and I believe that was the problem. I just gave them a twist and pushed down a little harder and that seemed to help.I have not had the problem since. Erik
 

·
Registered
Joined
·
482 Posts
Discussion Starter #3
No, these are aftermarket cables that clamp tight when you tighten the cable bolt.

Dave
 

·
Super Moderator
Joined
·
32,437 Posts
Probably need to do positive cable as well.

Battery I imagine is in good shape? Are the cables in good shape, menaing not corroded internally?

Everett
 

·
Registered
Joined
·
482 Posts
Discussion Starter #5
I'm going to do some checking today. I'll post what I find.

Dave
 

·
Moderator
Joined
·
10,147 Posts
OK, take it one more step. Either you haven't checked the water in the battery in a LONG time, or your alternator is overcharging for some reason.
If it overcharges the battery it will boil out the water like that. Is the battery wet near the caps a lot?
David

------------------
Check my web page for First Gen Camaro suspension info:
David's Motorsports page
First Gen Suspension Page
67 RS 327 original owner. 69 Camaro Vintage Racer, 65 Lola T-70 Chev SB Can-Am Vintage Racer
 

·
Registered
Joined
·
482 Posts
Discussion Starter #8
Thanks for the response. No, I normally don't see the battery top wet. I just haven't checked it in a long time. I will watch the level a little more closely now however.

Dave
 
1 - 8 of 8 Posts
Top