Team Camaro Tech banner

1 - 5 of 5 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
I installed a reproduction in-dash tach last Friday. The installation went smoothly. My car is a 1967 and did not have the in-dash tach option. But the printed circuit board accomodates a tach or no tach installation. At this point I don't know if the Tach works as is or not as my headers are out for coating and I can't start the car. Can anyone tell me what additional wiring I will need to complete. Any HELP will be much appreciated. Thanks

Dan Evans

------------------
Dan Evans
1967 SS 350 Coupe
 

·
Registered
Joined
·
448 Posts
Do you have a wiring diagram for your car. If not you need one. You will be able to check the wiring prior to firing it and troubleshoot from there. Which ignition you are running may or may not come into play. If its stock it should be plug and play. We hope.

------------------
Black 69 camaro
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
Thanks HOTROD69Camaro.
I have the MSD 6AL ignition with the Blaster SS coil. I'll check the MSD information and take a look at the wiring diagram info. I have. Will let you know the outcome.
 

·
Registered
Joined
·
448 Posts
I have that same ignition setup. I have no tach in my car yet. someday. See if you can search for 302xram on this site. I think he did a tach install in his 69 and I think he has MSD ignition. He told me he did'nt need the tach adaptor wiring. You might e-mail him and find out.

------------------
Black 69 camaro
 
1 - 5 of 5 Posts
Top