Team Camaro Tech banner

1 - 5 of 5 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
I installed a tow hitch on my 91 Camaro Z28 and wired the electrics into the brakes/side lights/left and right indicators. When I attach the trailer the brake and side lights work. The problem is with the indicators which flash faster and very dull on the car and trailer. I checked the earth on the trailer indicators and thats ok. Anyone come across this problem?
 

·
Registered
Joined
·
5,277 Posts
That's typical behavior for having too much load on the flasher. You can replace your flasher with a heavy duty type and it should be fine.
 

·
Registered
Joined
·
13,340 Posts
U could have 2 faults here..
Check the earths on the trailer...and that there is a earth connection between the car and trair in the connectors
The fast flashing is due to higher current being drawn thru the flasher unit.
This could also be due to the above...
OR as mantioned above the flasher unit is not rated for the car + trailer..
There are 2 types of basic flasher units...
1/rated to the current
2/A unit that is not current dependant,,,regardless of the number of lights it will still flash at the correct speed...it is these units that are normally installed on tow vechiles..
The draw back with these is u will not notice any change in flasher speed if a bulb goes out.
It is a simple operation under dash to unplug the old unit, plug the new in.
 

·
Premium Member
Joined
·
3,724 Posts
I vote for the HD flasher. Always worked for me and cheap
 
1 - 5 of 5 Posts
Top