Team Camaro Tech banner

1 - 9 of 9 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
Well I finnaly got done with the 454 project but now I am getting a strange niose. When the car is running there is a knocking and squeaking noise at the same time :confused: . The noise changes as I rev the engine or as I let in the clutch.It is pretty loud. The engine just had the heads redone and is farely fresh. What could be my problem here?
 

·
Registered
Joined
·
5,277 Posts
I've heard loose torque converters cause a concerning knock. Any chance the clutch didn't get sinched up good?

-dnult
 

·
Registered
Joined
·
1,047 Posts
I would take a look at the throw-out bearing as the source for the squeal. Also, did you install a new pilot bushing? If not, your tranny input shaft would have way to much room to move about and this is not a good thing ...
 

·
Registered
Joined
·
27 Posts
Discussion Starter #4
yea i replaced the bearing. So thats not it. I also have a 4 speed so I have no torque converter. Godd call though my dad just had that problem on his car and we fixed it. Mine on the other hand I dont no. could It be the pressure plate?
 

·
Registered
Joined
·
60 Posts
sounds like you might have to bite the bullet and drop the pan to check the lower end and pop off the valve covers and check the rockers
 

·
Moderator
Joined
·
10,144 Posts
I had a friend with a 454 newly rebuilt, he had no oil to the left side rocker arms. I never found out why that happened. It was an early 80's engine.
There were little piles of metal shavings under each rocker! :eek:
David
 

·
Registered
Joined
·
622 Posts
clutch disk installed backwards???

have you tried running the engine without belt driven accy's connected??

good luck
 
1 - 9 of 9 Posts
Top