Team Camaro Tech banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2,522 Posts
Discussion Starter #1
I just got back from my mechanic who has been working on my car for the longest. He started the engine for me and said that she should be ready by the end of this week. When he started the engine he showed me that he was forced to take my MSD ignition control box out because it wasn't putting out a spark anymore. :eek: He says that everything was going fine last night , then all of a sudden the engine shut off and would not start up anymore. After determining that the MSD box was the problem, he took it out and rewired the car back the way it was at first and restarted the engine without it.

This box is brand new :eek:

What do you all think could have happened that would kill this new $200 box
 

·
Registered
Joined
·
1,261 Posts
I agree, send it to MSD for repair or replacement. Electronics can fail at anytime and with no reason.
I can tell you a good story and why I'm sold on MSD. I had a new billet distributor from them and after about a month or so the rotor came off and broke the cap, pickup, and other things inside and under the cap. It was caused by the rotor screws backing off and starting the damage. I'm thinking it was my problem from not checking the bolts but I then sent it back to MSD and not too long later I get it back with no charges and a note saying sorry for the problem. That's getting kinda rare these days.
Jim
 

·
Registered
Joined
·
5,277 Posts
Originally posted by SOA-Nova:
Electronics can fail at anytime and with no reason.
Those MSD ignition systems don't hold smoke very well. Especially if the system voltage isn't well regulated. Using an MSD box on a stock buzzer regulated electrical system is asking for trouble.
 

·
Registered
Joined
·
2,522 Posts
Discussion Starter #5
Thanks guys

I've told several people about this and they all agree that I should simply send it back to them and they will fix it for free. My only concern right now is trying to figure out what happened that caused this malfunction in the first place. The last thing I want to do is have it repaired, re-installed, then have to pull it right back out again with the same problem :(
 
1 - 6 of 6 Posts
Top