Team Camaro Tech banner

1 - 8 of 8 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1
I installed the digital 6 ignition and it ran fine for about 1000 miles and then it just stopped firing. MSD tech support was very helpful and helped me diagnose the issue. It turned out the brain had failed and I had to send it back to the MSD factory and they repaired it at no cost to me. I just got the rebuilt box back and it started and ran fine for about 10 minutes now it has stopped firing. I have heard that MSD has had some quality issues latley. But i'am also curious has anyone else had this simular problem and what did you find the problem to be?

Topoff68 68 rag 427
 

·
Registered
Joined
·
13,338 Posts
I have heard that MSD has had some quality issues latley.
I believe those problems related to counterfeit units out of China.. not the genuine msd units.
Even so there are posts poping up on a regular basis ppl having issues of one kind or another.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #3
I bought the complete kit from summit the MSD digital 6, coil and distributor. When the first brain failed I mailed it back to MSD they are probably using cheap parts and labor.

Can I use the MSD distributor and coil with a different brain?
 

·
Registered
Joined
·
13,338 Posts
Dunno m8...
MSD multi spark discharge (at low rpms) in my books is a patch for an ignition/HT system that isnt working correct , hides faults that owners are too lazy or ignorant to fix...hence all the great reports /feed back..."my car ran like crap then the msd fixed (patched) it."

Plus having a bright red striped box that stands out like whores draws an clashes with any under hood colour schemed, in a proment place...make real good bragging /ego rights.
 

·
Premium Member
Joined
·
2,405 Posts
Dunno m8...
MSD multi spark discharge (at low rpms) in my books is a patch for an ignition/HT system that isnt working correct , hides faults that owners are too lazy or ignorant to fix...hence all the great reports /feed back..."my car ran like crap then the msd fixed (patched) it."

Plus having a bright red striped box that stands out like whores draws an clashes with any under hood colour schemed, in a proment place...make real good bragging /ego rights.
Steps - Not everyone runs an MSD box because they had a problem. My car needs the extra spark and ignition retard when on the nitrous. :thumbsup:
 

·
Premium Member
Joined
·
3,716 Posts
MSD's are sensitive to grounding problems. Make sure your ground is good.
 

·
Registered
Joined
·
13,338 Posts
Not everyone runs an MSD box because they had a problem. My car needs the extra spark and ignition retard when on the nitrous.
Yes fully agree and I run LPG that requires a stronger spark than a pionts system....Yes your nitrious and my lpg will run on a pionts system...I say run , not perform 100%, because different mixtures and gases have different resistances in the chamber that often require higher voltages to over come those resistances
Everett made a very good explanation on the principles a while back

and yes hi end systems be they ignition, cooling , brakes that are designed for full on race doesnt mean they are suitable for street.
Its along the same thing as Chrome for show black for race...chrome holds heat in an engine.
The right application for the right use.
 

·
Registered
Joined
·
8,349 Posts
Sorry, haven't had that issue but I've only got an old analog 6A box on my supercharged 4.3L S10. Good thing is it's set up to just yank/yank/plug and back to factory ignition if there's a problem. Seems there have been a few complaints about the digital stuff but maybe it's just sticking out.

What's the rest of your setup like? I reckon it's the distributor that requires the box not the 8360? Are both your box power/ground lines run directly to the battery? Is the small red wire "turn on" lead connected directly to the IGN spade on your fuse box not the old resistance wire at the engine bulkhead?
 
1 - 8 of 8 Posts
Top