Team Camaro Tech banner
1 - 6 of 6 Posts

·
Registered
Joined
·
996 Posts
Discussion Starter · #1 ·
This is a brand new heater install on my '68 (no AC). New control panel and switch, new duct resistor, heater box, heater core, fan, wiring, everything.

I have my dash/interior all put back together, but my fender is still off and when I hooked up the battery to test, I noticed I have 3 speeds working on my heater blower/fan, but it does not shut off completely. It stays running in the OFF position.

I read through some similar posts talking about the duct resistor and control switch, but some people (not all) said they "thought" the fan always stays on?? Can any 68 owner confirm the heater fan is supposed to stay on all the time the key is on? This just seems like the blower motor would burn out prematurely, and this fan is a pain to replace.

Any confirmation and/or suggestions would be greatly appreciated.
Thanks, Tony
 

·
Registered
Joined
·
4,562 Posts
Don't recall my 68 Camaro blower motor always running, but I do recall my 69 Pontiac blower motor always running. Guess GM had a better idea in 69, or more likely, it had something to do with the Pontiac having A/C.
 

·
Registered
Joined
·
996 Posts
Discussion Starter · #6 ·
Thanks everyone for your confirmation.
I removed the switch from the top of the control panel and I get 3 speeds and OFF using the switch manually, (perfect). When I reattach the switch and use the lever the fan does not shut off, (only low, medium, high). There is no adjustment on these mounts for the switch, only the cable and it was a new complete assembly, (repop). I will continue adjusting tomorrow and report back.
 
1 - 6 of 6 Posts
Top