Team Camaro Tech banner

1 - 8 of 8 Posts

·
Registered
Joined
·
652 Posts
Discussion Starter #1
got the UCA and LCA back on but when installing the QA1 coil overs I don't get how the thrust bearing kit sits on the shock.

Right now I have the two adjusters on the bottom and then big flat washer/ Bearing / Big Flat washer / Spring

It's just doesn't look right when the spring sits on top of the thrust bearing washers.
because the spring isn't flat all the way around it makes the washer sit unevenly. Its hard to explain unless you have done this before.
Am I missing something?

If you guys need a picture I can take one.


Thanks.
 

·
Registered
Joined
·
7,160 Posts
Does it go on the shock side? I think the spring is flat on that side right? I don't think it's intended for the spring to rotate in the pocket, just the adjuster to rotate on the bottom of the spring in the direction desired. I don't know what you looking at but have some idea.

Simple: Put the washer/spacer/bearing between the shock adjuster and the spring. The spring as far I can figure should be flat there.

Joe
 

·
Registered
Joined
·
652 Posts
Discussion Starter #3
Does it go on the shock side? I think the spring is flat on that side right? I don't think it's intended for the spring to rotate in the pocket, just the adjuster to rotate on the bottom of the spring in the direction desired. I don't know what you looking at but have some idea.

Simple: Put the washer/spacer/bearing between the shock adjuster and the spring. The spring as far I can figure should be flat there.

Joe

Joe, that's exactly how I have it but the spring isn't exactly flat all the way around which causes the thrust washer to sit kinda crooked on the adjuster.
 

·
Premium Member
Joined
·
2,177 Posts
Yep thats correct. Like Mark says, it's because you have it completely relaxed. Once you start adjusting the spring, the washer will go flat. The older style like I have didn't have the thrust bearing and you were sliding the washer on the adjustment ring. Found a trick for that. Spray WD40 on the washer and ring and it makes adjusting it up 100% easier. Just in case anybody doesn't have the thrust washer kit.
 

·
Registered
Joined
·
159 Posts
Thank you for the reply's. :thumbsup:

Now I can continue putting this back together.


Rich
Mine are the same as well Rich. It bugged me too but my engine isnt even in yet so was waiting to put weight on it. I also went with the QA1 Stocker Stars in the rear, and they are fully extended so hope that corrects as well. Right now there is only a rear end in the car, no gas tank interior, or drivetrain.

BTY was it you that said you have a set of power steering hoses in another post? Might be interested if you still have them...

Mike
 
1 - 8 of 8 Posts
Top