Team Camaro Tech banner

1 - 10 of 10 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Howdy folks, I just purchased my first Camaro last week, it's a '79 Berlinetta with a 350.

It runs fine as it is, though in the coming days I'll be replacing the plugs and plug wires, shocks, weatherstripping, and installing a radio/CD player (it came with an empty hole in the dash). The AC doesn't seem to work, but I can wait awhile to fix that, and the cruise control doesn't work either, but I'm not too concerned about it. I've also got to fix the fuel gauge, I think there is a ground problem because it's stuck all the way to the right.

Still, it's a beautiful car and I'm looking forward to many happy hours on the road and in the garage.

Joe
 

·
Registered
Joined
·
5 Posts
sounds like a very nice car.. I just got my first camaro also.. its a 1989 camaro dunno if its an rs or an iroc yet.. still trying to find info on it and there mostly wireing problems with it but its runs and drive and wow do these camaros fly... well since I am new here I figured id say hello to you
 

·
Premium Member
Joined
·
1,033 Posts
Cool. Had a neighbor move away last summer. He had a pristine '79 Berlinetta with a 305 and a....4-speed. Never see that in those cars. Car looked showroom clean, too. It was bonestock. Enjoy it!
 

·
Registered
Joined
·
3,064 Posts
Welcome Joe to Team Camaro. I used to have a 79 Berlinetta as well. Post some pictures if you can. :waving:
 

·
Premium Member
Joined
·
1,400 Posts
Welcome, Joe! :waving: Enjoy the ride. :beers:
 
1 - 10 of 10 Posts
Top