Team Camaro Tech banner

1 - 7 of 7 Posts

·
Registered
Joined
·
152 Posts
Discussion Starter #1
The backup lights on my '67 RS/SS don't light up when I shift into reverse. I've got a 4 speed. Where is the backup switch located? I haven't checked the bulbs yet. Brake lights and turn signals and tail lights work fine.

Steve
 

·
Registered
Joined
·
1,693 Posts
The switch is mounted to the transmission, and is activated via a rod attached to the reverse lever arm. If your car has a Hurst shifter (very common modification), the switch may have been left off or not re-connected.
 

·
Registered
Joined
·
152 Posts
Discussion Starter #3
Originally posted by Kyvox:
The switch is mounted to the transmission, and is activated via a rod attached to the reverse lever arm. If your car has a Hurst shifter (very common modification), the switch may have been left off or not re-connected.
Yep, mine has a Hurst shifter. Why do they always forget to reconnect the switch when a Hurst shifter is installed?
 

·
Registered
Joined
·
8,305 Posts
Hurst sells a reverse light switch for their shifters- like $20 or something like that- but i made a simple bracket and used a microswitch that the reverse lever on the shifter hits when i put it into reverse. been working good for 2 summers of driving so far.
 

·
Registered
Joined
·
125 Posts
Rick's sells the aftermarket hurst backup switch with a bracket ( hcp-7 ), Summit sells it for $23 ( HUU-2480003 ). I used this and it was no problem to get the position correct. It is a simple two wire setup.

Nothing like working reverse lights after owning my Camaro for 15 years.
 
1 - 7 of 7 Posts
Top