Team Camaro Tech banner

1 - 7 of 7 Posts

·
Premium Member
Joined
·
13,705 Posts
have no brake lights or turn signals ... turn signal switch BAD?
Most likely if both sides are out - as long as you've checked the fuse(s) and power to the switch first ;)

Check for power (12vdc), at the terminal connection for the switch, to the switch on the 'Pink' and to the rear on the green and yellow wires.
If power is there on Pink and not on others then switch is most likely bad ...
 

·
Premium Member
Joined
·
926 Posts
FYI, the wire is Pink at the flasher, then Purple on to the switch connector. Power for the brake lights (when the brakes are applied) is White at the connector.

Do your hazzards work?
 

·
Registered
Joined
·
234 Posts
Discussion Starter #5
FYI, the wire is Pink at the flasher, then Purple on to the switch connector. Power for the brake lights (when the brakes are applied) is White at the connector.

Do your hazzards work?
hazards work brake lights will work if i jump the white wire from brake switch
 

·
Super Moderator
Joined
·
32,611 Posts
hazards work brake lights will work if i jump the white wire from brake switch
If you disconnect the brake light switch and do a continuity check, DVM in OHMS function, across the switch with the brake pedal pressed, you should see continuity, less than 1 ohm, across the switch.

Or, use the voltage function, press the brake pedal and no battery voltage on other than white wire on the switch, then I would suggest the brake light switch is bad and needs replacement. Or, could be a corroded switch internally or corroded connector, broken wire within the connector, or just hosed.
 

·
Premium Member
Joined
·
13,705 Posts
Purple vs. Pink ... :thumbsup:

:eek: I will blame that on this 60+ YO memory :D
 
1 - 7 of 7 Posts
Top