Team Camaro Tech banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I just put in a new carburator in my '80 305.
works better but I'm having trouble with accelleration. At first the Edelbrock carburator just needs adjusting,but I noticed it has a tough time accellerating when the automatic tranie goes into 2nd. Ialsothought it could be out of time as well. What do you think?
 

·
Registered
Joined
·
112 Posts
The carb should be fine for your application. Go back through and double check everything ie. vacuum advance, line to vacuum advance, timing ancance wieghts in distributer and any vacuum leaks. hope this helps.

71 Camairo
 

·
Registered
Joined
·
112 Posts
srfm, the mechanical timing advance wieghts under your rotor button.

I thought the same thing Baby68RS but,looked up the part # and thats what it called for. He could have a need for re-jetting you think?

71 Camairo
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
O.K. yea I found out what the timing advance wieghts are now I looked up a chiltons book.
But now your saying it might be the carburator then? Just a litle foot note, I am having a little problem with it. It seems the wieght on the automatic choke likes to stick on high RPM's even when its hot.I had a mechanic put it in for me. And he told me theres no way that he can adjust it because they have the electric choke rivited together.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #9
To answer Baby68rs Question it's a 745 cfm if I remember correctly. Ichecked the specs and Edelbrock did specify the 305 for this model.The vacuum lines have been checked out.One of the mechanics sniped off a vacuum tank. Its a round cylinder.Anyway those two lines are closed. Could that be the problem?
 
1 - 9 of 9 Posts
Top