Team Camaro Tech banner

1 - 6 of 6 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter #1 (Edited)
My OER dash carrier for my '69 does not have holes to mount the top of the lenses for the speedometer and tach. I have been told by Classic Industries Tech Support that this is the was that they come. Also that you are supposed to somehow remove the machine screw insert out of the old dash and put it in the new OER dash.
(The lenses use machine screws that go into metal inserts in the plastic of the original dash).

Anyone go through this with an OER dash carrier... is this possible?
Thanks a million.
 

·
Premium Member
Joined
·
403 Posts
What year? On my 67 the OER carrier fit perfectly. I don't care for how shiny it is though. I don't think the factory was so glossy black. I replaced my original 67 carrier and it was much more of a flat black.
 

·
Registered
Joined
·
59 Posts
Discussion Starter #3
Its for my 69. Sorry I missed that.

Yes, I agree. A little bit too glossy but I'll take it if I could just get it installed!
 

·
Premium Member
Joined
·
3,434 Posts
Mine was fine from OER. I took the j-nuts off the original and put them on the new one. Holes were there for the lenses to attach.
I second this. Mine was fine.
 

·
Registered
Joined
·
59 Posts
Discussion Starter #6
I am really glad to hear that you guys didn’t need to drill your own holes. It didn’t seem right.
It will be really helpful to take this data back to the vendor/OER to get me a good part. It’s a bummer though, I’ve already modified this one for the tach and installed the instruments before I noticed the problem.

One point of clarification – about the J nuts – I am guessing they were mentioned for other areas of the dash because for my gauges they use embedded inserts in the carrier itself for the lens screws

Thanks guys! Very appreciative.
 
1 - 6 of 6 Posts
Top