Team Camaro Tech banner

1 - 2 of 2 Posts

·
Registered
Joined
·
620 Posts
Discussion Starter #1
after 383 install i now have some oil on top of my manifold. i took the car to another shop they took the manifold off and discovered 1 stripped bolt on the head, meaning the head with will need tap dye, and they said the manifold ports are smaller than the head ports meaning the manifold edlebrock 2701 ports are about 1 3/4 noth to south and the head ports are 2 1/4(approx) taking height here the width is also slightly diffrent, i called eddlebrock they say they purposely make their intakes that way, i called blue print engines but they were closed, to try and get the exact manifold they used when dynod..

i have never heard of such a thing in regards to the ports issue lol i thought all the manifolds for small blocks equal up correctly. i have heard of an RPM diffrence, anyways the new shop said they could use diffrent gaskets but im like wait wait wait, until i find out which intake manifold im suppose to be using, they also said the last shop had the distributor in wrong as the number 1 should be over some more, how can you putthe distributor in wrong? if its so far off the mark i figure the car would surely run like crap wouldnt it?

383 engine
patriot alluminum heads
 

·
Registered
Joined
·
34 Posts
The oil on the manifold is most likely coming from the intake bolts. The oil will work its way up the threads if they were installed without thread sealant. As far as the distributor being installed wrong, it sounds like they are saying that it was rotated from where the factory says it should be. In other words, the factory says the #1 wire should be at the 5 o'clock position and they had it at say 7 oclock. It will still run just fine, its just not visually correct.
 
1 - 2 of 2 Posts
Top