Team Camaro Tech banner

1 - 9 of 9 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
my 95 3.4L seems to run pretty good
but im only getting 16 MPG and i dont
hot rod it, i mostly cruise at less than
2000 PRM and rarely get on it at all.
are there possibly any sensors/etc that i should
change to improve my mileage?
any other suggestions? ...zimmy
 

·
Registered
Joined
·
247 Posts
How many miles is on it? Friend of mine had same prob and had a clogged cat and replaced 02 sensors and straightened it out. Also try cleaning air filter. It's not breathing like it's suppose to.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #3
it has almost 118000 on it.....
the air filter is clean.
replacing the 02 sensors seems like
a good idea....i want to replace "all"
of the sensors on the motor, but im
a little broke right now so im tring to
prioritize till i get some cash .....z
 

·
Registered
Joined
·
1,394 Posts
Wow, 16 mpg is terrible for a six. I like the O2 sensor and catalytic converter replacement idea. If your state has vehicle emissions, you might have them hook the car up and do a read out and see if everything is good. ...... Oh, btw, you could try disconnecting the battery for a while, then hooking it back up. This should cause the computer to relearn everything and it 'might' run better.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #7
i changed the 02 sensors yesterday...seemed to run a little better till today when it decided not to start. z
 

·
Registered
Joined
·
201 Posts
leaking fuel pressure regulator?
 
1 - 9 of 9 Posts
Top