Team Camaro Tech banner

1 - 4 of 4 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
I have a 406 with 10 to 1 compression, Trick Flow heads, Performer Intake, General Kinetics 268 cam, recurved HEI distributor,headers and dual exhaust, 2400 stall, and 3.42 posi, all in a 78 Camaro. My problem is my part throttle response seems soggy. Full throttle the car will scream but part throttle it seems like I have to press the throttle further than I should need to to accelerate. I have tried several carbs and 2 different distributors, but no change. Any suggestions are greatly appreciated.
 

·
Moderator
Joined
·
10,142 Posts
Make sure your mechanical advance is all in by 2500 or so.
If the mech advance comes in too slowly, it will make the mid range sluggish.
On an HEI the weights would have to have the finger end opposite the weight trimmed down a bunch to come in that quickly.
Also watch for the advance freezing up due to corrosion on these distributors.
David

------------------
Check my web page for First Gen Camaro suspension info:
David's Motorsports page
First Gen Suspension Page
67 RS 327
69 Camaro Vintage Racer
65 Lola T-70 Chev 350 Can-Am Vintage Racer
 

·
Registered
Joined
·
3,692 Posts
What kind of carb are you running? May just need some fine tuning.

------------------
375hp 78 Chevy truck
77 Chevy Nova
95 Chevy Lumina 3.4L
and building a 78 Nova
 

·
Registered
Joined
·
25 Posts
Discussion Starter #4
OK I got everything sorted out. I had an Edelbrock 750 on it. I tried a freshly rebuilt QJet jetted to 396/350 specs and the car will scream now. Thanks heaps
 
1 - 4 of 4 Posts
Top