Team Camaro Tech banner

1 - 5 of 5 Posts

·
Premium Member
Joined
·
4,060 Posts
Discussion Starter #1
brand new AED 4150 carb
set floats and pump shot
initially I had a bog from standing start.
changed cams and shooters (BIGGER)
second road test:
stomped the throttle and spun tires through first into second.

next day
warm car up to temp as before.
step on gas and bog is back???????
took off pump arms and bent the arms a little.
readusted accel pump for .015 at WOT.
ok back to smoking tires!
next day same ol bog again?
this got me scratchin my head?????
maybe bigger accel pumps ????
 

·
Premium Member
Joined
·
6,628 Posts
brand new AED 4150 carb
set floats and pump shot
initially I had a bog from standing start.
changed cams and shooters (BIGGER)
second road test:
stomped the throttle and spun tires through first into second.

next day
warm car up to temp as before.
step on gas and bog is back???????
took off pump arms and bent the arms a little.
readusted accel pump for .015 at WOT.
ok back to smoking tires!
next day same ol bog again?
this got me scratchin my head?????
maybe bigger accel pumps ????
dawg,
Ive been threw the same thing with my Pro-System 4150. It might be a little lean on the mixtures AFR screws. Also vacuum when take off with a 4-speed or an auto with a big cam will be tricky to get this bog out. I ran a vacuum gauge in the car to see what my vacuum would go down to when i release the clutch to help me dial the carb in better for this hesitation.
 

·
Premium Member
Joined
·
4,060 Posts
Discussion Starter #5
ok think I fixed it!
I had carb powder coated and powder coater coated entire carb inside and out?
looking at the metering block and comparing with a non powder coated block i see the holes are a bit smaller.
So I measured holes on non coated block and made the holes on the coated block the same.
reinstalled and readjusted pump shot and hasnt bogged all day!:hurray::thumbsup:
 
1 - 5 of 5 Posts
Top