Team Camaro Tech banner

1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I am about ready to just give up and put back in the 41 year old sloppy crap manual steering box! At least I know it works. So after switching over to power steering and ordering THREE quick ratio rebuilt power steering boxes all of which did not work properly:angry: probably due to the fact there made in china. Sorry for the rant I had to vent. So I bit the bullet and ordered a delphi 600 series steering box which had a hefty price tag for my 69 camaro. So after putting the box in the car and getting it all bolted up I was putting the line adapters in that were included with the box and the only one that fits is the high pressure side. The one for the return line is to big or the hole in the ps box is to small:mad:. I was wondering if anyone has had this problem before or would know a solution. thanks in advance for any help
 

·
Premium Member
Joined
·
5,992 Posts
I didn't have a problem with my Delphi 600 and adapters but I remember
they were little aluminum mushroom-shaped pieces. They were not exactly alike and I had to call about which one went in which hole. They sit recessed in the box's ports as a mushroom would grow on the ground. I hope that helps you.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Yea that does thanks. Because both of the little aluminum adapters we got were the same size. I guess I will have to call and have them send the right ones.
 

·
Premium Member
Joined
·
5,992 Posts
I think I remember that correctly...I have an extra set that I can check at home, I will try to find them and check. It'll be worth the aggravation when you get it working.
 

·
Premium Member
Joined
·
5,992 Posts
Well, I couldn't find my extra set, dang it. So, I'm just going by memory but I still believe the two should be different, fwiw.
 
1 - 5 of 5 Posts
Top