Team Camaro Tech banner

1 - 3 of 3 Posts

·
Registered
Joined
·
140 Posts
Discussion Starter #1
I moved my ECM and Ign Amplifier to a location on the core support. I fab'd a bracket on the core support and mounted the ECM on one side of a metal plate, and the Ign Amp on the other side...they are mounted back to back.

So now it has occured to me that the Ign amp may create electrical interferance with the ECM..... I know that Fast EFI recommends the ign box and the ECM be at least 2 feet apart.

Thoughts?
 

·
Registered
Joined
·
182 Posts
One could just try it...but since common sense says that the ignition amplifier is pretty 'dirty'...mounting next to the ECU is almost asking for trouble.

I would prefer a location to hide both elsewhere...maybe one behind each headlight bucket...that is closer to 4 feet apart.

I put my ECU under the passenger seat inside the car...no MSD.

Good Luck!
 

·
Registered
Joined
·
8,349 Posts
You're more likely to pick up interference through the wiring proximity to high voltage than the actual unit which is most likely the reason for the two foot rule. Might be good to try the MSD noise filter also. I used one on a truck with MSD to help with some radio noise. Didn't work, but I think it's because the MSD is mounted in the engine bay back corner close to where the antenna runs through the fender.

My unit has the ECM connected directly to the throttle body and the main wiring harness and wideband harness come right off the back and are practially under the dizzy and coil (MSD mounted to firewall above passener valve cover). No issues with that but my engine, frame, and body are grounded to hell and back. It uses a removable cable to connect a laptop and back when I had an HEI I used to just leave the cable installed and run under the dizzy, behind the valve cover, and through the blower motor grommet in the firewall so I could run the laptop in the seat while driving. Didn't have an issue until changing out the HEI for an MSD 8360 and Blaster coil over the valve cover. Then it wouldn't keep connection. No issues with the actual ECM though.
 
1 - 3 of 3 Posts
Top