Team Camaro Tech banner

1 - 8 of 8 Posts

·
Moderator
Joined
·
15,370 Posts
Discussion Starter #1
Putting my steering column back together tonight and pouring through the chassis manual. I replaced the 2 old bolts for the coupler on the shaft with stainless grade 8's and then took a look at the joint on the steering box.

I seem to be missing some part(s) of the rubber joint itself. I can't figure out why a piece of rubber would be bolted! The pics in the manual aren't any help other than to show some type of clips or brackets on the rubber and then the bolts go through it and the cutouts on the shaft coupler.
The rubber joint on my steering box doesn't have any type of fasteners or anything on it and it looks like there's indentations on the steering box side where SOMETHING was there, like washers. Repair kits don't include anything but the rubber joint and bolts. No type of fasteners or brackets or anything. I can't find an actual picture of the whole rag joint anywhere to compare.
AM I missing something here?

Thanks!
 

·
Premium Member
Joined
·
991 Posts
there should be a shoulder strap around half the rag joint. it receives the bolt on the gear box side of the rag joint. If you need one, i have one left over from my recent replacement @n/c. Somehow, it sounds like you may have lost the shoulder strap.
 

·
Registered
Joined
·
1,035 Posts
Throw the repair kits out...Get a complete coupler or you'll be doing the job again real soon. Some companies won't even sell the repair kit because they're not very safe.
 

·
Moderator
Joined
·
15,370 Posts
Discussion Starter #4
That's good to know Panther. And that's exactly what the description says about the one's on Ricks First Gen. catalog site.
I guess I didn't look at enough catalogs to realize more than just the repair kits were offered.
Thanks Joe, I really appreciate the offer but I might as well replace the whole thing just for nothing else but so it'll look a little better next to all the new paint that's going on everything.
 

·
Registered
Joined
·
166 Posts
hwy star joe
Just finished mine on my 68. The repair kits are junk and a waste of money! I had to order one from ricks and was happy. It came with the right stuff. The bolts were correct and the pins were right. Being cheep cost me a couple more days, a lot of cussing and one big headache! :D
 

·
Moderator
Joined
·
15,370 Posts
Discussion Starter #6
Yeah, I know how ya feel having to wait days at a time for the simple, small stuff. I looked at AutoZone, NAPA and Advance and none of them sell a replacment joint. At least not specifically for a Camaro or Nova. I'm sure with enough time and research, we could find a suitable substitute over the counter.
 

·
Premium Member
Joined
·
823 Posts
I have my original one out of my 67 laying in the garage somewhere...
 

·
Banned
Joined
·
21,341 Posts
And remember that a tilt column has a different bolt-on top half then a non-tilt column that I think is welded on!!

pdq67
 
1 - 8 of 8 Posts
Top